XUbuntu: Make Shift + NumPad funziona come Windows

25

Ok, ho usato Ubuntu con GNOME per un po ', ma ora sto usando XUbuntu. In Ubuntu, c'era una preferenza per la tastiera che rende il tastierino più sano di mente, era chiamato qualcosa come "Make Shift + NumPad funziona come Windows".

Il problema che risolve questa opzione è che quando si preme NumPad 7, si comporta come il tasto "Home", che va tutto bene, ma se si preme Shift + NumPad 7, si comporta come il tasto "7", che non va bene perché sono su un laptop e la normale chiave "Home" mi obbliga a fare una mossa anatomicamente folle. Ad ogni modo, questa opzione ha fatto in modo che Shift + NumPad 7 si comportasse come il tasto "Home".

Non riesco a trovare questa opzione sotto XUbuntu. Come faccio a impostarlo?

Aggiornamento: GUI o riga di comando, non importa.

    
posta Raphael R. 14.08.2011 - 20:35

5 risposte

37

Dopo un po 'di grepping ho trovato la soluzione: è necessario aggiungere l'opzione numpad:microsoft a XkbOptions. Su Ubuntu più vecchio, fallo nel tuo xorg.conf. Su quelli più recenti apri il file /etc/default/keyboard e cambia questa riga:

XKBOPTIONS=""

a

XKBOPTIONS="numpad:microsoft"

Salva e riavvia (il riavvio di X sembra non funzionare, almeno non con RAlt + PrintScreen + K). Potrebbe essere necessario eseguire sudo dpkg-reconfigure keyboard-configuration affinché le modifiche abbiano effetto.

    
risposta data Raphael R. 15.08.2011 - 16:52
15

Ubuntu 14.04 non ha più "Varie opzioni di compatibilità" nelle impostazioni della tastiera. Anche modificare /etc/default/keyboard non è una soluzione funzionante. Ma il database di dconf contiene le opzioni richieste con la chiave /org/gnome/desktop/input-sources/xkb-options . Questa opzione dovrebbe essere completata con numpad:microsoft in qualcosa come ['grp:alt_shift_toggle', 'grp_led:scroll', 'numpad:microsoft'] manualmente in dconf-editor o usando questo script:

# !/bin/bash
old='gsettings get org.gnome.desktop.input-sources xkb-options'
new='echo $old | sed "s/'numpad:microsoft'//g" | sed -r "s/(, )+/, /g" | sed -r "s/(, )?]/, 'numpad:microsoft']/"'
gsettings set org.gnome.desktop.input-sources xkb-options "$new"
    
risposta data tbrush 22.07.2014 - 08:26
11

Sono contento di aver trovato il tuo post. Usando Natty Narwhal, ho trovato un'opzione simile nelle impostazioni della tastiera.

  1. Cerca tastiera
  2. Fai clic sulla scheda Layout
  3. Fai clic sul pulsante Opzioni
  4. Espandi varie opzioni di compatibilità
  5. Controllare "Shift con i tasti del tastierino numerico funziona come in MS Windows"
  6. Chiudi e stai bene!
risposta data Kit Menke 16.08.2011 - 04:40
8

In Xubuntu 16.04 l'impostazione XKBOPTIONS (XKBOPTIONS="numpad: microsoft") in / etc / default / keyboard è ignorata - lo considero un bug.

Sto usando il seguente comando come soluzione:
setxkbmap -option 'numpad:microsoft'

Per eseguire automaticamente il comando sopra riportato all'avvio del grafico ambiente desktop, ho creato una voce di avvio automatico dell'applicazione:
Menu & gt; Impostazioni & gt; Sessione e avvio & gt; Autostart dell'applicazione & gt; Aggiungere

  

Nome: Make Shift + NumPad funziona come MS Windows
  Descrizione: qualunque
  Comando: setxkbmap -option 'numpad:microsoft'

    
risposta data F.M. 26.09.2016 - 23:57
2

Ho avuto un problema simile su lubuntu. Ho provato a cambiare il file /etc/default/keyboard , ma non è stato di aiuto.

Penso che la ragione potrebbe essere che ho cambiato layout sul mio sistema. Tuttavia, l'aggiunta di numpad:microsoft nel campo "Opzioni avanzate setxkbmap" nelle opzioni del gestore di layout di tastiera ha funzionato. Non ho nemmeno dovuto riavviare la X.

    
risposta data Alexander Belov 02.04.2016 - 18:35

Leggi altre domande sui tag