jungledisk non riesce con errore libnotify

16

Qualcuno ha avuto successo nel far funzionare l'applicazione jungledisk sotto Ubuntu?

L'ho installato dal file .deb fornito da jungledisk. L'installazione va bene, ma non riesco ad avviare l'app "jungle disk desktop".

Viene visualizzato nella barra di ricerca del trattino, ma non si avvia o non esegue nulla quando lo si seleziona.

Quando provo la riga di comando, ottengo il seguente ...

$ jungledisk -V -f
Verbose mode enabled
Shutting down...
$

Ottengo qualcosa di più interessante con il seguente comando ... qualcosa su libnotify.so

$ junglediskdesktop -V -f
junglediskdesktop: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

Qualcuno ha suggerimenti su cosa provare?

    
posta Angelo 01.12.2011 - 01:20

4 risposte

16

Gli utenti di helpticket su jungledisk / rackspace hanno risolto questo problema. Sembra che il jungledisk stia aspettando libnotify.so.1 e ubuntu abbia avuto libnotify.so.4.

La creazione di un collegamento simbolico che punta a libnotify.so.4 risolve il problema ...

  

Il nuovo Ubuntu manca di libnotify.so.1 necessario per jungle disk. Questo   viene risolto creando un collegamento simbolico a libnotify.so.4 a libnotify.so.1.   Prego [inserisci i comandi] qui sotto e riavvia la macchina:

     

cd /usr/lib/i386-linux-gnu/ ; sudo ln -s ./libnotify.so.4 libnotify.so.1

     

Saluti, JungleJason

    
risposta data Angelo 02.12.2011 - 04:51
15

Per una versione a 64 bit di Ubuntu, l'altra risposta non funzionerà, perché i percorsi delle librerie rilevanti sono diversi. Tuttavia, la soluzione dai forum linuxmint funziona:

sudo ln -s /usr/lib/x86_64-linux-gnu/libnotify.so.4 /usr/lib/libnotify.so.1 
    
risposta data Kailash 13.12.2011 - 21:09
0

Ho avuto lo stesso problema. Finisci usando gli strumenti Linux gratuiti di SMEStorage:

link

    
risposta data Cory Killian 01.12.2011 - 08:39
0

Rackspace ha pubblicato una serie ufficiale di istruzioni su: link Per entrambe le versioni a 32 e 64 bit. Nota come al momento la soluzione non funziona correttamente con Ubuntu 13.04.

    
risposta data Bryce 12.11.2013 - 05:35

Leggi altre domande sui tag