Come si disabilita il suono drum beat nella schermata di login?

112

Mi sarei aspettato Sistema ▸ Amministrazione ▸ Schermata di accesso ▸ Riproduci il suono di accesso per controllarlo, ma deselezionandolo non impedisce il suono della batteria dal suono.

    
posta ændrük 05.02.2011 - 19:05

15 risposte

59

Il suono di avvio può essere disabilitato modificando la configurazione di Unity Greeter. Eseguendo quanto segue da un terminale lo farà:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Se stai usando Ubuntu 12.04 LTS assicurati di aver installato gli aggiornamenti poiché questa funzione è stata aggiunta in un aggiornamento.

    
risposta data Andrejs Cainikovs 25.04.2016 - 23:34
58

Per Ubuntu 12.04 +

LightDM Way

Conosciuto anche come FluteFlute Slap, LightDM Way richiede il logout e sulla schermata di login LightDM puoi cambiare il volume o persino silenziare il suono.

Nel Login Greeter puoi vedere il volume in alto a destra. La regolazione del volume non influisce sul volume all'inizio della sessione, quindi puoi MUTE il suono nel Greeter senza disattivare l'audio all'avvio della sessione:

UbuntuTweakWay

LamodalitàUbuntuTweakimplicaildoverscaricarel'appUbuntuTweakequindidisabilitareilsuonodalì.Effettuaiseguentipassaggiepuoifarloinquestomodo:

sudoadd-apt-repositoryppa:tualatrix/ppasudoapt-getupdatesudoapt-getinstallubuntu-tweak

ApriUbuntuTweakenellaschedaTweakselezional'opzione"Impostazioni di accesso", dovresti vedere l'opzione Riproduci l'audio di login. Devi fare clic sul pulsante Blocca in alto per poterlo modificare.

PerUbuntu11.10eseguenti

VaiaSystem->Preferences->StartupApplications

Disabilita quello chiamato GNOME Login Sound

(deseleziona la casella e fai clic su Chiudi)

puoi anche andare a System -> Preferences -> Sound e disabilitare l'intero sistema audio (come suoni di Windows, avvisi, ecc.)

Nella versione precedente potevi andare alla parte Sound Preference e selezionare ogni suono e cosa volevi fare. È stato rimosso intorno alle 9.04 o alle 9.10. Sarebbe bello se tornasse.

    
risposta data Luis Alvarado 05.02.2011 - 19:20
54

12.04 - 16.10 (LightDM)

Ecco cosa ha funzionato per me dopo aver installato 12.04 la scorsa settimana.

I passaggi sono questi, adattati da link :

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Aggiungi queste righe:

[com.canonical.unity-greeter]
play-ready-sound = false

Salva, quindi esegui:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Riavvia e divertiti.

    
risposta data K. P. MacGregor 10.09.2012 - 13:11
20

11,10 (LightDM e GDM)

Soluzione rapida:

Apri un terminale ed esegui il comando

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

Il suono della batteria lightdm per sistema pronto può essere disattivato in modo simile

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
    
risposta data RobinJ 15.10.2011 - 13:23
11

Per 12.04

Per impostazione predefinita, è disattivato. Per abilitarlo, apri un terminale ed esegui

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Quindi modifica il valore per X-GNOME-Autostart-enabled su "true", ad es. % Co_de%

Per 11,10

Scrivi su un terminale X-GNOME-Autostart-enabled=true e cambia il valore gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop da true a false :

Oravaialletueapplicazionidiavvioedovrestivedereedessereingradodidisabilitarel'opzionenecessaria:

    
risposta data Bruno Pereira 15.10.2011 - 13:26
10

10.10 (GDM)

Sembra che ci sia un bug nella schermata di login a riguardo. Non riesco a trovare un rapporto ufficiale, tuttavia questo post sul forum conferma un correggere.

Vai a Sistema / Amministrazione / Schermata di accesso. Sbloccalo, quindi fai clic su "Riproduci il suono di accesso".

Chiudi la finestra, quindi torna di nuovo nell'app, sblocca, quindi deseleziona la stessa opzione.

    
risposta data Scaine 05.02.2011 - 20:43
7

Se utilizzi GDM con 12.04

Per disabilitare i suoni di accesso, il tasto suoni-evento sotto org.gnome.desktop.sound per l'utente gdm deve essere impostato su falso.

Per questo, dobbiamo prima assegnare a GDM la proprietà della propria home directory. Apri un terminale e digita: sudo chown -R gdm:gdm /var/lib/gdm

Quindi esegui:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

e disconnessione (o riavvio).

Se si utilizza LightDM con 12.04

Apri un terminale con Ctrl + Alt + T e digita / incolla quanto segue, una riga alla volta:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

Ciò che fa è disabilitare l'impostazione play-ready-sound per lo schermo di accesso / gestore desktop (lightdm).

    
risposta data ish 10.09.2012 - 12:15
5

11,10 (LightDM e GDM)

Per rimuovere il suono di avvio:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Per abilitare il suono di avvio

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Per rimuovere il suono di accesso (dopo aver effettuato l'accesso):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Per abilitarlo di nuovo:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
    
risposta data Vibhav Pant 07.03.2012 - 09:03
3

11,10 (LightDM e GDM)

Questo dovrebbe funzionare per te.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Quindi modifica NoDisplay = false, ect.

o per rimuoverlo:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
    
risposta data Ringtail 07.03.2012 - 09:02
3

11,10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
    
risposta data blueyed 30.09.2011 - 09:13
1

12,10 (GDM)

Nessuno dei precedenti funziona per me con gdm. Se disattivo il suono pronto per il sistema (i bongo), emette comunque un breve suono di batteria (un battito).

Il modo per disabilitarlo è:

  • Avvia, entra in gdm.
  • Passa alla console ( Ctrl + Alt + F1 )
  • Accedi
  • Invio:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Torna a gdm ( Ctrl + Alt + F8 )

  • Disabilita il suono nel mixer. Ho disattivato l'audio in "Riproduzione" e "Dispositivi di output".
  • Chiudi il mixer, potresti ricevere un errore sulla scrittura del file di configurazione, questo è innocuo.
  • Torna alla console e inserisci

    sudo service gdm restart
    

    per testare e exit per uscire.

risposta data jdm 17.07.2012 - 18:02
1

11.04 e precedenti (GDM)

Esegui questo comando in un terminale?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

    
risposta data Jorge Castro 11.09.2012 - 05:49
1

12,10 (LightDM)

Esegui lo stesso comando Jorge Castro ha dato , solo con gdm sostituito per lightdm :

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    
risposta data C Schilder 27.06.2012 - 09:51
1

Il modo più semplice è solo per disattivare l'audio nel saluto. Fai semplicemente clic sul volume e fai clic su "Disattiva audio".

Disattiva l'audio solo nel greeter.

    
risposta data Pilot6 15.06.2015 - 12:48
0

12.04 (LightDM)

Il suono del bongo LightDM non può essere disabilitato tramite qualsiasi opzione GUI in 12.04 e qui c'è un bug report:

I metodi della riga di comando sopra possono disabilitarlo.

L'audio dopo il login può essere facilmente disabilitato con le risposte sopra.

    
risposta data Eric Nemchik 07.04.2012 - 04:04

Leggi altre domande sui tag