non può aprire il file oggetto condiviso: nessun file o directory [chiuso]

16

Problema con questo file /tmp-air-nkhvxz-setup-error-while-loading-shared-libraries-libgtk-x11-2-0-so-0

Cerco di risolvere questo problema e provo a installare libgtk-x11-2.0.so.0

sudo apt-get install libgtk2.0-0:i386

sudo apt-get install ia32-libs

ma due link sopra non funzionano. Ce n'è un'altra alternativa?

    
posta Mert METIN 25.12.2012 - 18:53

3 risposte

15

Ho lo stesso problema e non sono stato in grado di finanziare soluzioni su Internet, per me non ha funzionato. Finalmente sono riuscito a farlo funzionare semplicemente installando la libreria grafica libgtk2.0-0: i386 da Ubuntu Software Center.

Puoi anche digitare il seguente comando in un terminale:

sudo apt-get install libgtk2.0-0:i386
    
risposta data Elvedin Hamzagic 01.11.2013 - 10:03
8

Per risolvere questo problema. Devi installare ia32-libs-gtk , che è un pacchetto virtuale di ia32-libs . Prova anche a installare libglib2.0-dev

sudo apt-get install ia32-libs libglib2.0-dev

Se quanto sopra non ha funzionato, prova a installare

sudo apt-get install libgtk2.0-0

La libreria condivisa che hai menzionato appartiene a libgtk2.0.0 . Quindi il comando sopra dovrebbe risolvere il problema.

Se stai usando Ubuntu a 64 bit, prova

sudo apt-get install libgtk2.0-0:i386

Questo ha funzionato in 14.04 LTS

    
risposta data devav2 25.12.2012 - 19:58
-1

Devi installare alcune librerie:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386
    
risposta data bfree2run 30.01.2014 - 00:51

Leggi altre domande sui tag