Impossibile collegarsi a VPN usando gnome-network-manager

17

Sto usando Ubuntu 14.04. Inizialmente volevo connettersi automaticamente alla VPN al momento del login, ma dopo molti tentativi ed errori di connessione sembra che il mio gestore di rete sia corrotto.

Quando provo a connettere Wifi facendo clic su Indicatore di rete - & gt; Connessioni VPN - & gt; (My VPN) Non ho ricevuto conferma dalla GUI che non è stato possibile connettersi.

Quando ho fatto tail /var/log/syslog , ho ottenuto:

Aug 25 19:59:01 NetworkManager[1041]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Aug 25 20:00:07  NetworkManager[1041]: <info> Starting VPN service 'openvpn'...
Aug 25 20:00:07 NetworkManager[1041]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 3544
Aug 25 20:00:07 NetworkManager[1041]: <info> VPN service 'openvpn' appeared; activating connections
Aug 25 20:00:07 NetworkManager[1041]: <error> [1408993207.745279] [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Aug 25 20:00:07 NetworkManager[1041]: <info> Policy set 'MY WIFI CONN' (wlan0) as default for IPv4 routing and DNS.
Aug 25 20:00:13 NetworkManager[1041]: <info> VPN service 'openvpn' disappeared
    
posta TheMayne 25.08.2014 - 21:03

8 risposte

4

Ho appena avuto lo stesso problema e la risposta di Plant Maven era corretta.

Invece di eliminare i file di configurazione in /etc/NetworkManager/system-connections/ li ho spostati in un'altra cartella, quindi ho potuto confrontare.

L'unica differenza tra il vecchio file di configurazione e quello nuovo è in una connessione VPN che ho appena ricreato da zero ed è l'UUID.

Non ho idea del motivo per cui il vecchio file non avrebbe funzionato. Sospetto che si tratti di qualcosa relativo al portachiavi.

    
risposta data alex_223 03.02.2015 - 21:33
3

Nel mio caso la selezione dell'opzione password "Memorizza la password per tutti gli utenti" ha funzionato. Tutte le altre opzioni producono l'errore citato.

    
risposta data Stefan 18.11.2017 - 12:57
1

Ho appena recuperato tutti i file in / etc / NetworkManager / system-connections / e riavviato Ubuntu 14.04. Problema risolto. So che è stato l'ultimo aggiornamento del software perché ho aggiornato e chiuso. La prossima volta che ho avviato Ubuntu, la rete continuava a perdere la connessione.

    
risposta data user347724 11.11.2014 - 18:05
1

Si prega di osservare che Gnome Network Manager è cambiato e ora quando si modificano le connessioni si ha un simbolo a destra nel campo Password che indica come deve essere gestita la password, "Memorizza password solo per questo utente", "Memorizza il password per tutti gli utenti ", Richiedi questa password ogni volta e la password non è richiesta. È necessario selezionare "Richiedi la password ogni volta" se si desidera la domanda di password la seconda volta Questo mi ha confuso un po '....

    
risposta data eplkurt 06.10.2017 - 13:36
0

Ho provato a spostare / eliminare le connessioni in /etc/NetworkManager/system-connections/ , scegliendo l'opzione "Memorizza la password per tutti gli utenti" e "La password non è richiesta" (per la mia VPN, non lo è), reinstallando il gestore di rete, riavvio di Ubuntu, .. Nessuno di questi ha funzionato.

Le mie connessioni funzionavano, ma solo periodicamente. Ho provato solo alcune volte il comando openvpn , ma ha funzionato perfettamente.

Per risolvere il problema, modifica la connessione e fai clic su

Advanced - & gt; spunta Accept authenticated packets from any address (Float)

quindi salva la connessione. Questa è stata l'unica cosa che ha funzionato per me.

    
risposta data Code Bling 25.04.2018 - 07:51
0
sudo apt-get install --reinstall network-manager

Dopo aver eseguito questo comando, ho provato a connettermi al servizio VPN, mi è stato per fortuna ancora una volta richiesto la mia password vpn e in grado di connettermi al servizio.

Dopo alcune settimane, a volte ho ancora problemi. Quando esco e accedo, si risolve per la maggior parte del tempo. Ora utilizzo anche il gestore di rete WICD, a causa del fatto che a volte le fermate wifi funzionano completamente!

    
risposta data TheMayne 26.08.2014 - 23:16
0

Anch'io ho avuto questo errore anche se l'ho incontrato dopo una settimana di utilizzo impeccabile di OpenVPN. Ho trovato un'idea oscura per riavviare il servizio dbus in Ubuntu.

    sudo service dbus restart

Potrebbe essere saggio concatenare un altro comando a questo comando per riavviare la GUI poiché un riavvio del pulsante di accensione era necessario per me dopo aver eseguito questo comando

    
risposta data santhon88 28.05.2015 - 11:13
0

controlla questo forse dovresti eliminare il gestore di rete e reinstallare il pacchetto gestore di rete che scarichi o dal cd live

    
risposta data jake 26.08.2014 - 08:11

Leggi altre domande sui tag