"Il servizio di autenticazione non è disponibile" durante l'installazione di IDLE (usando python 2.7)

16

Ho ricevuto questo errore durante l'installazione di IDLE in 12.10:

Software can't be installed or removed because the authentication service is not available.
(org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.95'}): 
org.debian.apt.install-or-remove-packages

Non riesco a installare nulla, nemmeno i giochi. Vengono tutti con lo stesso messaggio di errore.

C'è qualcosa che mi manca? Si prega di suggerire.

    
posta Gagan 28.10.2012 - 07:18

3 risposte

6

Una soluzione temporanea a questo è:

sudo software-center
    
risposta data Paschalis 26.11.2012 - 12:01
2

Prova questo:

sudo apt-get update
sudo apt-get install idle3

Inoltre, è possibile che il gestore pacchetti sia bloccato da un altro processo, come un aggiornamento in background o un'altra installazione che non è stata completata. Puoi provare a riavviare, quindi emettere quanto segue, che completerà le installazioni incomplete:

sudo dpkg --configure -a
    
risposta data Da1T 14.11.2012 - 20:31
1

C'erano alcuni aggiornamenti in sospeso per la mia installazione di ubuntu. Ho aggiornato la mia ubuntu e tutto ha funzionato bene per me dopo.

Grazie per tutto il tuo aiuto

Con cordiali saluti Gagan Janjua

    
risposta data Gagan 15.11.2012 - 22:35

Leggi altre domande sui tag