Come installare rgdal su Ubuntu 12.10?

16

Sto cercando di installare rgdal library su Ubuntu 12.10.

L'installazione dall'interno di R produce un errore:

  

Errore: gdal-config non trovato Lo script gdal-config distribuito con   GDAL non è stato trovato. Se non hai installato le librerie GDAL,   puoi scaricare la fonte dal link se hai   installate le librerie GDAL, quindi assicuratevi che gdal-config sia in   Il tuo percorso. Prova a digitare gdal-config al prompt della shell e verificane la presenza   piste. In caso contrario, utilizzare:   --configure-args = '- with-gdal-config = / usr / local / bin / gdal-config' con i valori appropriati per l'installazione.

     

ERRORE: configurazione fallita per il pacchetto 'rgdal'   * rimozione '/home/rdk/R/x86_64-pc-linux-gnu-library/2.15/rgdal' Avvertenza in install.packages: l'installazione del pacchetto 'rgdal' era   stato di uscita diverso da zero

R-sig-Geo , ​​questo due domande SE e altri siti web mi hanno indicato i requisiti di libgdal1-dev .

Ma quando ho provato

  

sudo apt-get install libgdal1-dev

Finisco con un altro messaggio di errore

  

Alcuni pacchetti non possono essere installati. Questo potrebbe significare che tu hai   richiesto una situazione impossibile o se si sta utilizzando l'instabile   distribuzione che alcuni pacchetti richiesti non sono stati ancora creati o   stato spostato da Incoming. Le seguenti informazioni possono aiutare a   risolvi la situazione:

     

I seguenti pacchetti hanno dipendenze non soddisfatte: libgdal1-dev:   Dipende: libgdal-dev ma non verrà installato E: impossibile   correggi i problemi, hai tenuto i pacchetti danneggiati.

Ancora una volta - quando provo a installare libgdal-dev , viene visualizzato un altro errore di dipendenza

  

I seguenti pacchetti hanno dipendenze non soddisfatte: libgdal-dev:   Dipende: libgeos-dev ma non verrà installato                  Dipende: libspatialite-dev ma non verrà installato

Anche in questo caso, prova libgeos-dev a dare il messaggio:

Depends: libgeos-c1 (= 3.3.3-1.1) but 3.3.3-2~precise2 is to be installed
E: Unable to correct problems, you have held broken packages.

e libspatialite-dev :

Depends: libspatialite3 (= 3.1.0~rc2-1ubuntu1) but
3.1.0~rc2-2~precise1 is to be installed

C'è un modo per domare queste dipendenze e avere rgdal in esecuzione su Ubuntu?

Il mio sessionInfo()

  

R versione 2.15.1 (2012-06-22)   Piattaforma: x86_64-pc-linux-gnu (64-bit)

    
posta radek 26.10.2012 - 01:59

5 risposte

24

Una risposta più recente può essere trovata qui: link .

Essenzialmente, le tre seguenti righe di codice dovrebbero essere ordinate:

sudo apt-get install aptitude # install aptitude as an alternative to apt-get
sudo aptitude install libgdal-dev # install the package (you may have to respond to queries here)
sudo aptitude install libproj-dev # install the proj.4 projection library

Hai passato anni su questo problema, quindi spero che questa risposta aggiornata sia utile per gli altri. Fammi sapere se è così!

    
risposta data RobinLovelace 26.11.2013 - 02:31
12

Prova a eseguirli tutti insieme e specificando le versioni, ad esempio:

sudo apt-get install libgdal1-dev libgdal-dev libgeos-c1=3.3.3-1.1 libspatialite3=3.1.0~rc2-1ubuntu1

apt-get non gradisce il downgrade dei pacchetti, ma lo farà se lo specifichi.

    
risposta data Rucent88 01.11.2012 - 06:16
4

Qui a gennaio 2016, su Ubuntu 14.04.2 (e con R 3.2.2), avevo bisogno di quanto segue per ottenere sia rgdal e il complementare (e spesso molto utile) gdalUtils pacchetto installato:

sudo apt-get update
sudo apt-get -y install libgdal1h
sudo apt-get -y install libgdal1-dev
sudo apt-get install libproj-dev
sudo apt-get install gdal-bin
Rscript 'install.packages(c("rgdal", "gdalUtils"))'

Aggiornamento: come a gennaio 2017, la versione di libgdal è 1i, quindi la seconda riga di codice dovrebbe essere:

sudo apt-get -y install libgdal1i
    
risposta data Josh O'Brien 26.01.2016 - 04:54
3

Apri il terminale premendo (Ctrl + alt + T) e scrivi il seguente comando.

  

sudo apt-get update

     

sudo apt-get install -f

(Risolverà le dipendenze.)

  

sudo apt-get autoremove

(rimozione dei pacchetti non necessari)

  

sudo apt-get clean

(Cancella cache)

    
risposta data Ketankumar Patel 26.10.2012 - 08:26
3

Per ottenere rgdal da installare su Ubuntu 12.04, ho dovuto installare (e tenere) molti pacchetti specifici per la versione. Fondamentalmente ho provato ogni pacchetto e installato le versioni richieste delle dipendenze finché non ho potuto ripristinare l'obiettivo originale, per installare libgdal1-dev

sudo apt-get install libspatialite3=3.0.0~beta20110817-3
echo libspatialite3 hold | sudo dpkg --set-selections
sudo apt-get install libspatialite-dev
sudo apt-get install libgeos-c1=3.3.3-1.1~pgdg12.4+1
echo libgeos-c1 hold | sudo dpkg --set-selections
sudo apt-get install libgdal1=1.9.0-3.1~pgdg12.4+1
echo libgdal1 hold | sudo dpkg --set-selections

sudo apt-get install libgdal-dev
sudo apt-get install libgdal1-dev
gdal-config # now works, and can now install rgdal
    
risposta data toms 06.03.2014 - 16:47

Leggi altre domande sui tag