"ctrl + spazio" è stato associato a invocare qualche metodo di input e non funziona in Emacs o Eclipse si completa automaticamente

81

In Emacs eseguito nel terminale, ctrl + spazio è un tasto di scelta rapida standard per selezionare la regione. Ma con Ubuntu 12.04, invocherà alcuni metodi di input per la lingua non inglese. Mi stavo chiedendo se posso riservarlo solo per Emacs?

Sotto System Settings -> Keyboard -> Shortcuts , non sono riuscito a trovare ciò che ctrl + spazio è stato associato. Strano.

Anche altri programmi, in particolare il completamento automatico in Eclipse, sembrano avere un problema nella gestione di ctrl + spazio .

    
posta Tim 16.01.2013 - 00:55

8 risposte

119

Sembra che tu abbia Ibus in esecuzione, che usa Ctrl + Spazio di default per abilitare / disabilitare l'editor di input.

È possibile modificare il tasto di scelta rapida ad esso assegnato in Preferenze Ibus.

Se Ibus è in esecuzione nella barra dei menu, puoi fare clic con il pulsante destro del mouse per scegliere Preferenze dal menu. Se Ibus non è in esecuzione nella barra dei menu, puoi avviare la finestra di dialogo Preferenze da Dash eseguendo Metodi di input da tastiera o dal terminale con ibus-setup .

Aggiornamento per 14.04

ibus-setup non è più disponibile per 14.04. Le funzioni del precedente ibus-setup sono invece integrate in Impostazioni di sistema & gt; & gt; Inserimento di testo .

Il cambio di input ora è impostato su Super + Spazio , ma Ibus potrebbe ancora rubare lo stato attivo dallo spazio Control + keybinding e causa altri problemi di sistema, in particolare il completamento automatico in Eclipse.

L'integrazione della commutazione dell'ingresso Ibus nelle nuove impostazioni dell'inserimento testo è ancora in corso e ciò causa il problema poiché l'impostazione precedente esiste ancora dietro le quinte.

Se hai effettuato l'aggiornamento dalla 12.04, ibus-settings dovrebbe essere ancora disponibile.

In 14.04, puoi modificare direttamente le impostazioni è dconf-editor .

Se non è installato:

sudo apt install dconf-editor

Quindi vai a Desktop & gt; & gt; ibus & gt; & gt; generale & gt; & gt; hotkey . L'impostazione trigger e triggers mostrerà ancora 'control + space'. Modifica queste impostazioni, facendo attenzione a lasciare parentesi vuote [] in triggers .

    
risposta data chaskes 16.01.2013 - 01:59
10

Disabilita il trigger IBUS usando la linea di comando:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Se ciò non funziona, prova se il primo produce un errore:

gsettings set org.freedesktop.ibus.general.hotkey triggers []
    
risposta data aba 24.06.2014 - 09:46
4

ibus non mi provoca altro che mal di testa. Ogni volta che provo a cambiare le impostazioni, quando riavvio, Ctrl + Space ritorna. Ecco la mia soluzione:

sudo apt-get purge ibus
sudo killall ibus

Ora tutto funziona finché Ubuntu non decide la loro prossima stupida cosa. Forse la lettera "o" verrà mappata per spegnere il computer?

    
risposta data Eyal 11.02.2015 - 13:47
2

Dopo l'aggiornamento a Ubuntu 14.04, ho avuto lo stesso problema. Quello che ho fatto.
Nelle preferenze di Ibus: % Co_de%.
C'è un'opzione: System > Preferences > Keyboard Input Methods è stato impostato su ctrl + spazio, l'ho rimosso e poi tutto ha iniziato a funzionare di nuovo.

    
risposta data wmlynarski 24.07.2014 - 11:04
1

Ubuntu Studio 14.04 (XFCE) qui. Non ho avuto problemi con il completamento automatico ( Ctrl + Space ), ma con Copia riga ( Ctrl + Alt + Down ).

Questo ha funzionato per me:

  • Apri Windows Manager: xfwm4-settings
  • Vai alla scheda Tastiera
  • Scorri verso il basso fino all'azione in conflitto
  • Premi il pulsante Cancella o cambia azione in un altro collegamento
risposta data luboskrnac 04.04.2015 - 13:34
0

Ho Ubuntu 14.04 GNOME con LXDE. Apparentemente questo desktop ha ibus-setup. Quindi, per me, cambiare l'impostazione di ibus era la soluzione giusta. Forse è stato solo Unity a eliminare l'app di ibus-setup.

    
risposta data JamesH 28.12.2014 - 05:28
0

Il cambio dconf-editor non è stato sufficiente per me. Ho installato la sorgente di input Mozc (giapponese).

Su Ubuntu 16.04, dovevo anche:

  1. Vai a Impostazioni di sistema - & gt; Inserimento di testo
  2. Fai clic su Mozc per evidenziare
  3. Fai clic sull'icona della chiave inglese / del cacciavite sotto
  4. scheda Config globale
  5. La prima impostazione lì, "Metodo di input trigger", era CTRL_SPACE. Ho fatto clic e poi ho premuto Escape per rimuovere la combinazione di tasti.
risposta data TalkLittle 08.09.2016 - 19:18
0

Per alcune persone che usano l'input giapponese con fcitx, controlla Fcitx Configuration . C'è un menu per la configurazione globale e sotto Trigger Input Method , il collegamento predefinito sarà Ctrl + Spazio .

    
risposta data 19.09.2018 - 03:33

Leggi altre domande sui tag