Caratteri brutti in Netbeans - Come posso usare il carattere di sistema?

67

Ho problemi nel far sì che il font di Netbeans sia bello, questo è stato un problema da quando ho provato Ubuntu ~ 8. Per qualche ragione i font sembrano non ricevere il subpixel smoothing solo in Netbeans, per il resto delle applicazioni sembrano perfetti.

Guarda quanto è brutto lo screenshot:

Non è solo l'area del codice, ma ogni carattere nell'applicazione appare in questo modo. Mi sono guardato attorno e apparentemente aggiungere la seguente riga al file .bashrc dovrebbe risolvere il problema ma nel mio caso non lo era:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'

Pensa che potrebbe interessare solo le applicazioni basate su Java, ma non sono stato in grado di testare un'altra app Java per controllare i font.

Qualcuno sa cosa posso fare per risolvere questo problema? Come posso fare in modo che Netbeans usi il carattere di sistema?

    
posta Javier Villanueva 30.03.2011 - 07:58

16 risposte

38

Come è stato affermato nei commenti, questo è un problema con le app di Java Swing su Linux. Swing utilizza le impostazioni di smoothing dei font di Gnome (disattivato, in scala di grigi o subpixel) - tuttavia ignora le impostazioni di suggerimento. Utilizza sempre un suggerimento completo, e se stai eseguendo Ubuntu con pochi o nessun suggerimento sui font (come la maggior parte delle persone, dato che il piccolo suggerimento è l'impostazione predefinita) questo farà apparire il carattere significativamente diverso rispetto ad altre applicazioni. Le applicazioni SWT come Eclipse vanno bene, ma se ti piace Netbeans questo non ti aiuterà.

Avvertenza: per la seguente soluzione, sto solo parlando del font dell'editor, perché in un IDE è ciò che è importante per me. Puoi anche applicarlo ai font di menu, ecc., Ma potrebbe essere un po 'esagerato.

L'unica soluzione utilizzabile che ho trovato qui : usa Fontforge per modificare il font del tuo editor di scelta e rimuovere tutte le informazioni di suggerimento dal font stesso, quindi salvarlo come nuovo font e utilizzarlo in Netbeans.

  1. sudo apt-get install fontforge
  2. Avvia Fontforge
  3. Apri il font di tua scelta
  4. Ctrl + A o edit -> Select -> Select all per selezionare tutti i caratteri
  5. Suggerimenti ⇒ Cancella istruzioni
  6. Ctrl + Maiusc + F o element -> font info per aprire le informazioni sul carattere
  7. Rinomina font (ad esempio, nel nome originale + '_nohints')
  8. Salva il font modificato nella directory .fonts nella tua home, tramite file -> generate fonts , assicurandoti di utilizzare un formato letto da Ubuntu (vedi il passaggio successivo)
  9. Cancella la cache del carattere fc-cache -rv - seguendo il suo output per assicurarti che il nuovo file font sia stato prelevato (ad esempio .sfd non fa ma .ttf fa).
  10. Avvia Netbeans e usa il carattere che hai creato come carattere di editor

No, non perfetto e sì, un po 'di seccatura, ma ancora un mondo di differenza. Spero che ti aiuti.

    
risposta data nem75 21.04.2011 - 23:12
16

Aggiungi

--laf Nimbus -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

o

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

al file: netbeans.config. Puoi trovarlo in $ NETBEANS_HOME / etc / folder. Rendi il font dell'applicazione più piccolo rispetto alle preferenze di sistema.

Source

    
risposta data user24789 11.09.2011 - 10:03
7

So che questa è una vecchia domanda, ma nella mia ricerca dello stesso problema, ho provato tutti i trucchi qui senza fortuna. Pensavo che avrei dovuto vivere con un testo terribile in netbeans.

Poi ho trovato questo: link

In sostanza: Ubuntu 13.10, Netbeans (7.3), patch di font Infinity per freetype, OpenJDK7 e patch per risolvere il problema della gestione dei font di Swings. E "ha funzionato" !!!

Copia qui nel caso in cui il link muoia:

  1. installa freetype

    $ sudo apt-get install libfreetype6
    
  2. installa la patch infinality

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo apt-get update
    $ sudo apt-get install fontconfig-infinality
    

    Ho dovuto fare quanto segue in seguito:

    $ sudo rm /etc/fonts/conf.avail/52-infinality.conf
    $ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf
    

    Per usare Windows 7 come il rendering dei font, procedi come segue:

    $ sudo /etc/fonts/infinality/infctl.sh setstyle win7
    

    Imposta USE_STYLE su "WINDOWS7" in /etc/profile.d/infinality-settings.sh

  3. installa font fixed OpenJDK

    $ sudo add-apt-repository ppa:no1wantdthisname/openjdk-fontfix
    $ sudo apt-get update
    $ sudo apt-get install openjdk-7-jdk
    

    In .../etc/netbeans.conf ,

    netbeans_default_options include: -J-Dawt.useSystemAAFontSettings=lcd e % Co_de%

    e impostare % Co_de%

Questo ha cambiato i miei font Netbeans dal 1990, accettabile per il giorno moderno fantastico. E ora posso usare Inconsolata come il mio font dell'editor Netbeans e sembra GRANDE.

Schermata come richiesto: (il testo attuale è più chiaro di questa acquisizione, qualcosa nella cattura lo ha leggermente sfocato).

    
risposta data Chris Holt 31.01.2014 - 06:28
5

L'anti-aliasing dei caratteri non funziona correttamente nelle applicazioni Java Swing di Ubuntu.

Add:

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

in netbeans.config alla fine della stringa netbeans_default_options .

Puoi trovare il file di configurazione nella cartella $ NETBEANS_HOME / etc / (ad esempio /home/<user_name>/<neatbeans_folder>/etc/netbeans.conf )

Esempio:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd"
    
risposta data R. Oosterholt 24.01.2014 - 10:53
2

Non è così male quel tipo di carattere ..

Tuttavia, questa è un'applicazione Java e un modo particolare di gestire i font.

Se vuoi solo cambiare la dimensione del carattere, puoi avviare Netbeans con " - fontsize "parametro :

netbeans --fontsize 12

Se vuoi cambiare il tipo di carattere, è un po 'più difficile cambiare i parametri dell'ambiente, e questo articolo spiega molto bene:

link

Questo è per ArchLinux, ma penso che funzionerà anche in Ubuntu dato che Java è un software universale.

    
risposta data Pisu 10.10.2011 - 23:52
2

Ho avuto lo stesso problema su Ubuntu 12.04 e Netbeans 7.2.

Ho provato ad aggiungere -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd a netbeans.conf ma non ha risolto il problema.

Poi ho visto il commento del problema relativo all'altezza della linea in bug Netbeans 215785 . Impostare l'altezza della riga dell'editor su 1.0 insieme alle impostazioni AA in netbeans.conf ha risolto il mio problema.

    
risposta data Caner 01.09.2012 - 15:48
1

Sono riuscito a farlo in questo modo (sto usando Ubuntu 12.10, ho lavorato anche su Ubuntu 13.04):


Passaggio 1 (Probabilmente funziona in tutte le versioni di Ubuntu):

Per prima cosa ho ripulito i menu usando questo plugin Tools -> Plugins -> Settings -> Add :

http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

Una volta aggiunta questa posizione, è necessario installare il plug-in, cercando Java Ayatana (la descrizione sarà in spagnolo). Questo renderà il top e il menu contestuale lo stesso del sistema operativo.


Passaggio 2 (Non so se funzionerà in tutte le versioni di Ubuntu):

Successivamente probabilmente vorrai che i font dei progetti siano anche più belli, quello che ho fatto per risolverlo è stato eseguito nel terminale: sudo apt-get install gnome-tweak-tool L'ho lanciato e ho scelto un diverso default font Ora Netbeans sembra carino!

Ecco uno screenshot:

    
risposta data Get Off My Lawn 22.12.2012 - 23:49
1

Ho appena visto questo post e ho cercato di risolvere il problema dei miei font, avevo anche un problema, potevo scegliere solo 4 font tutti erano zoppi, e mi chiedevo cosa fosse successo che netbeans dava solo 4 font tra cui scegliere e anche lame chooser box, Sono un grande fan di netbeans e sapevo di poter trovare una soluzione qui.

in qualsiasi modo ho seguito tutti i possibili guid. Io uso Ubuntu 13.10 e netbeans 7.3 (sì, adoro le cose instabili)

  1. crea la cartella .font nella mia cartella utente.
  2. copia tutti i font che ho avuto in quella cartella.
  3. ha aggiunto la seguente riga al file netbeans.conf

trovalo eseguendo:

locate netbeans.conf

modificalo e aggiungi quanto segue all'interno delle virgolette come suggerito sopra

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal
  1. esegui l'aggiornamento di netbeans che penso abbia fatto la magia ora ho un bel selettore di caratteri e ho più caratteri da scegliere, quindi codice da scrivere (scherzo non praticato).

Spero ti possa aiutare.

    
risposta data talsibony 01.01.2014 - 15:24
0
#!/bin/sh

gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
sh /home/xxx/netbeans-7.2/bin/netbeans &
sleep 5
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 11'
    
risposta data demonige 19.09.2012 - 13:53
0

Personalmente, penso che l'aspetto generale predefinito di Netbeans su Linux sia un po 'deludente, soprattutto considerando quanto è bello su altre piattaforme. Per fortuna, cambiando il look & amp; feel (LAF) può essere fatto facilmente dall'interno dell'IDE. A seconda della selezione, questo spesso migliorerà l'aspetto dei caratteri.

Per cambiare il LAF, fai quanto segue: Fai clic su Strumenti & gt; & gt; Opzioni Nella finestra di dialogo, selezionare Aspetto e quindi la scheda Aspetto Basta selezionare uno dei LAF. La mia preferenza è Nimbus, ma potresti preferire qualcos'altro.

Ci sono anche due plugin "Dark LAFs" disponibili: Dark Metal e Dark Nimbus.

    
risposta data Larry Hignight 24.07.2014 - 03:12
0

Facendo un ulteriore passo avanti verso le modalità manuali, ho preparato un font dedicato denominato "Ubuntu Mono Nohinting" per risolvere un problema di rendering con applicazioni Java Swing come NetBeans IDE, IntelliJ IDEA e PyCharm. Le informazioni di suggerimento sui font sono state rimosse dalla famiglia di font originale di Ubuntu Mono.

Come installare

  • scarica il file zip da qui
  • estrailo
  • apri * .ttf con Font Viewer da installare.
  • o puoi copiare manualmente * .ttf in ~/.local/share/fonts/ .

Come usare

  • Seleziona "Ubuntu Mono Nohinting" nella configurazione degli editor.

Immagini

Font Ubuntu Mono con tema PyCharm Monokai

FontNohintingdiUbuntuMonocontemaPyCharmMonokai

    
risposta data Nobuto Murata 11.04.2015 - 18:15
0

Io stesso ho fatto una cosa leggermente diversa: nel mio caso, parlando di NetBeans versione 8.0.1 , il problema era il JDK installato sul sistema (Oracle JDK 8.0). Dopo il passaggio a OpenJDK, sono stati visualizzati 8 caratteri più carini negli elementi dell'interfaccia utente.

Non so se questa è una buona risposta, perché potrebbe non funzionare ovunque, ma certamente - provando cambiando JDK (sia OpenJDK che Oracle JDK) potresti vedere una differenza.

    
risposta data spectre 21.12.2015 - 18:18
0

Aggiungi il seguente codice alla fine del netbeans_default_options del tuo file netbeans.conf .

-J-Dawt.useSystemAAFontSettings=on

Questo farà uso dei caratteri di sistema.

    
risposta data Kevin RED 29.11.2017 - 13:25
0

Ho provato letteralmente tutte le soluzioni che ho trovato e nessuna ha funzionato tranne che per l'utilizzo di un JDK predefinito diverso per NetBeans.

Il JDK di Oracle non rende bene i caratteri. Anche OpenJDK non sembra funzionare con NetBeans ma fa meraviglie per IntelliJ e per i suoi fratelli.

Quello che ha funzionato per NetBeans è chiamato TuxJDK che è essenzialmente OpenJDK migliorato per gli sviluppatori Java che lavorano su Linux. Uno dei miglioramenti è rendering dei font eccellente .

Ecco come usarlo:

  1. Scarica il binario TuxJDK da qui . ("tuxjdk-static-8.92.03.tar.xz" al momento della scrittura)
  2. Estrai il file tar.xz dove preferisci.
  3. Copia il percorso della directory TuxJDK.
  4. Apri netbeans.conf in NetBeansInstallationDirectory / etc /.
  5. Trova la linea che inizia con "netbeans_jdkhome" e sostituisci il percorso con quello copiato nel Passaggio 3.
  6. Accendi i NetBeans e tratta i tuoi occhi con dei bellissimi font!

Prima: NetBeans prima di utilizzare TuxJDK

Dopo: NetBeans dopo aver utilizzato TuxJDK

    
risposta data Rohit Awate 23.03.2018 - 17:26
0

Installa zulu jdk dal link :)

    
risposta data Arun 30.03.2018 - 14:39
-1

Avevo lo stesso problema su Mint 12. L'ho risolto inserendo le "Impostazioni avanzate" - & gt; "Caratteri" e riducendo il carattere predefinito da 11 a 10. Ho ridotto tutti i caratteri nell'elenco alla coerenza.

Ci deve essere qualche problema con il font Cantarell 11.

    
risposta data Alan B. Dee 23.12.2011 - 19:25

Leggi altre domande sui tag