A quale versione di Debian sono basate le diverse versioni di Ubuntu?

71

Ho alcuni pacchetti software personalizzati per Ubuntu 10.04, 10.10 e 12.10, ma ora devo installarli su Debian Squeeze. Non sono riuscito a Google per una mappatura tra specifiche versioni di Ubuntu e Debian. Qualcuno può aiutarti?

In particolare voglio sapere quale versione di Ubuntu corrisponde a Debian Squeeze.

    
posta xkcd 09.04.2014 - 16:28

2 risposte

138

Puoi trovare la versione di Debian su cui si basa la tua versione di Ubuntu nel file: /etc/debian_version

Dal 10.04 al 17.04:

   Ubuntu      |       Debian  
18.04  bionic     buster  / sid   - 10
17.10  artful     stretch / sid   - 9
17.04  zesty      stretch / sid
16.10  yakkety    stretch / sid
16.04  xenial     stretch / sid
15.10  wily       jessie  / sid   - 8
15.04  vivid      jessie  / sid
14.10  utopic     jessie  / sid
14.04  trusty     jessie  / sid
13.10  saucy      wheezy  / sid   - 7
13.04  raring     wheezy  / sid
12.10  quantal    wheezy  / sid
12.04  precise    wheezy  / sid
11.10  oneiric    wheezy  / sid
11.04  natty      squeeze / sid   - 6
10.10  maverick   squeeze / sid
10.04  lucid      squeeze / sid

sid è la distribuzione di sviluppo di Debian (sid - testing - stable)

Puoi scoprire il contenuto del file senza installare un intero sistema visualizzando i sorgenti del pacchetto basefiles su Launchpad .

    
risposta data Jacob Vlijm 09.04.2014 - 16:43
5

Sfortunatamente non esiste una mappatura diretta / etc / debian_version come menzionato nella risposta di Jacob dà un'idea approssimativa ma riflette solo un pacchetto e detto pacchetto è un pacchetto che viene modificato localmente in Ubuntu quindi non verrà automaticamente richiamato da Debian.

In particolare, Ubuntu spesso precede Debian su pacchetti core come libc6. È probabile che il tentativo di installare un pacchetto basato su Ubuntu su una versione contemporanea di Debian finisca con errori di versione su libc6.

Secondo link Debian spremere had libc6 2.11. Secondo il link ubuntu 10.04 lucido aveva anche libc6 2.11 . Quindi i pacchetti per 10.4 lucidi sono IMO quelli con maggiori probabilità di funzionare su Squeeze.

A seconda delle altre librerie richieste dal tuo programma, potresti scoprire che è necessaria una build specifica per Debian Squeeze.

    
risposta data Peter Green 20.04.2016 - 17:42

Leggi altre domande sui tag