"Richiedi l'installazione di pacchetti non attendibili" durante l'aggiornamento con il gestore aggiornamenti

65

Non ha corretto l'errore. Quindi, come posso risolvere il mio aggiornamento della GUI?

Per ogni software devo installarlo dalla riga di comando perché ho ricevuto lo stesso errore quando installavo software da Ubuntu Software Center.

    
posta One Zero 29.03.2012 - 13:55

7 risposte

63
  1. Scrivi in ​​un terminale: sudo apt-get update && sudo apt-get upgrade o modifica le impostazioni di Update Manager (prova prima se hai già configurato Update Manager).

  2. Avvia Update Manager e riprova.

L'esecuzione dell'aggiornamento tramite un terminale fornisce l'opzione se consentire o meno pacchetti non sicuri.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Se ti fidi dell'origine del pacchetto, digita y .

    
risposta data Zlatan 29.03.2012 - 19:14
43

Questo succede a causa della mancanza di alcune chiavi GPG. Per risolvere questo problema, apri un terminale ed esegui i seguenti comandi:

sudo apt-get update

Si riceverà un errore che dice che alcune chiavi pubbliche non sono disponibili. Nota la stringa di chiavi (dopo NO_PUBKEY; es .: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Sostituisci XXXXX con la stringa di tasti

es .: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

es .: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Ora prova ad aggiornare di nuovo il tuo sistema.

Ecco un post simile: "Richiede l'installazione di aggiornamenti non attendibili" Errore in Update Manager

Spero che questo aiuti.

    
risposta data aneeshep 01.12.2010 - 10:05
13

Puoi installarlo tramite la riga di comando: sudo apt-get install --allow-unauthenticated exiv2 .

Per "fidarsi" permanentemente del repository, esegui questo: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update . Credo che sia il PPA che stai usando.

    
risposta data evgeny 01.12.2010 - 10:12
5

In risposta alla tua domanda, non puoi "correggere" l'aggiornamento della GUI (ad es. Update Manager), perché è evidente che quella applicazione non ha attualmente la possibilità di installare pacchetti non fidati. Se vuoi installare pacchetti non fidati, devi farlo dalla riga di comando.

Esistono tuttavia due modi per impedire a Update Manager di segnalare questo errore: rimuovere il software non attendibile dal sistema OPPURE fidarsi il repository in questione, come descritto nella risposta all'altra domanda ( Gli aggiornamenti non vengono installati a causa di "pacchetti non attendibili" ) .

Il primo passo è scoprire quale repository sta causando il problema. Puoi scoprirlo digitando apt-cache policy ambiance-colors nella riga di comando.

Tuttavia, un rapido google rivela che ambiance-colors e radiance-colors provengono da ppa:ravefinity-project . Quindi dovresti essere in grado di risolvere il tuo problema digitando

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

tratto da link

    
risposta data stackex humanoid 10.06.2012 - 22:06
1

perché il suo modo di dire significa che i pacchetti che stai tentando di installare sono software di terze parti. Quindi, se vuoi installarli, abilita la casella Canonical Check in un'altra scheda del software nelle impostazioni di update manager e poi riprova installazione.

spero che aiuti.

    
risposta data Ten-Coin 29.03.2012 - 19:21
1

Ho avuto lo stesso problema. Per me, questo comando ha funzionato:

sudo apt-get update --fix-missing

Il vantaggio di questo rispetto alle altre soluzioni è la sua semplicità. È possibile continuare a utilizzare la GUI e non è necessario scoprire quale repository è danneggiato. Ho trovato la soluzione qui in un commento. Non conosco abbastanza Ubuntu da spiegare, ma suppongo che abbia le chiavi necessarie per far funzionare tutti i repository.

    
risposta data smoortema 20.09.2013 - 10:58
0

La tua domanda non è chiara: tu "aggiusti l'aggiornamento della GUI" correggendo l'errore. L'altra domanda ti mostrerà cosa fare.

Puoi deselezionare qualunque cosa dei tuoi aggiornamenti si basi su una fonte non attendibile, oppure puoi andare avanti e usare la riga di comando per fidarti in modo permanente di quell'origine specifica. Una volta che hai fatto uno di questi, il messaggio non comparirà. Se esegui quest'ultimo, il messaggio non verrà più visualizzato per quella specifica fonte.

    
risposta data Mei 29.03.2012 - 19:04

Leggi altre domande sui tag