La rete wireless non funziona dopo la ripresa in Ubuntu 14.04

78

[Aggiornamento]:
Lo stesso problema esiste in Kubuntu e viene risolto allo stesso modo.
[Risolto]:
Applicando il seguente comando nmcli nm ho ottenuto quanto segue:

Prima di sospendere

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

come puoi vedere lo stato è connesso e il resto è abilitato e in esecuzione

Dopo la sospensione

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

come puoi vedere lo stato è addormentato, il che significa che il nostro caro gestore di rete sta ancora dormendo, quindi per risolvere usa la linea di comando a cascata:
sudo nmcli nm sleep false
questo dice al gestore della rete di svegliarsi. per fare questo permenante:
crea uno script in /etc/pm/sleep.d che contenga quanto segue (e non dimenticare di contrassegnare lo script come eseguibile):

#!/bin/sh

case "" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

Grazie a questo

Il problema originale:

Ho appena scaricato Ubuntu 14.04 e installato sul mio laptop: ASUS X61SL con processore Intel P8400 Core2Duo x64.
Quando chiudo il coperchio, il sistema è sospeso, ma quando apro di nuovo il coperchio e riprendo, la rete wireless non viene attivata (l'intera rete è disabilitata) e quando seleziono "Abilita rete" non accade nulla.
Questa è l'informazione sul mio adattatore wireless:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Questo problema non era presente in Ubuntu 13.04, Linux Mint Debian Edition o Debian 7 wheezy (GNOME o KDE).

Modifica: pochi test con i seguenti risultati:
Il problema riguarda le mie reti wireless e cablate.
Nota: ho bisogno di aggiungere la riga pci=nomsi a grub per avviare.
Quando si disconnette manualmente, quindi sospendi, quindi riprendi il log in ogni cosa funziona bene.
Quando si sospende direttamente mentre si è connessi, il problema si verifica.
Il blocco e la sospensione provocano lo stesso problema della sospensione diretta.
Anche questo problema sembra influire sulla funzione di disconnessione: se si è scelto di uscire dal menu utente nel pannello dell'unità, non si desidera disconnettersi, ma se si utilizza la riga di comando gnome-session-quit --logout , è possibile disconnettersi.
Ora con lshw -C network output:
Normale (networking completamente funzionale):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Dopo il ripristino ("/etc/pm/config.d" non contiene "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Quando ho aggiunto il file unload_modules alla directory "/etc/pm/config.d" come suggerito da qui , dopo aver effettuato il logout, sospendere, riprendere quindi accedere al lavoro di rete ma non riesco a connettermi alla rete wireless.
Di nuovo il risultato di lshw -C network Dopo il ripristino ("/etc/pm/config.d" contiene "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Il contenuto di "unload_modules" dove:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

Dove 'ath9k' è il mio modulo wireless e 'sis190' è il mio modulo Ethernet.

    
posta Ossama Nasser 22.04.2014 - 15:13

5 risposte

27

Le risposte sopra non hanno funzionato per me il 14.10. Dopo un po 'di tentativi ed errori, ho finito con questo,

#!/bin/sh

case "" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Metti questo in /etc/pm/sleep.d/10_resume_wifi
Rendilo eseguibile sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi e il problema dovrebbe essere risolto immediatamente.

    
risposta data Owais Lone 13.04.2015 - 22:03
21

Ho una soluzione, ma è solo per riavviare il tuo gestore di rete.

sudo service network-manager restart

Non è la soluzione permanente.

    
risposta data hmjha 20.03.2016 - 11:40
4

Lo script che alla fine ha funzionato per me:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

L'altra risposta ha errori di battitura (possono essere corretti, lo so), ma non ha mai funzionato comunque per me.

    
risposta data Augustin Riedinger 31.03.2015 - 09:21
0

Questo ha funzionato per me su Ubuntu 14.04 su Dell Precision laptop.

In un terminale, inserisci:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Quindi incollare (ctrl + v):

#!/bin/sh
case "" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Quindi rendi eseguibile lo script:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Esegui il test di sospensione e riattivazione per vedere il wifi acceso !!

    
risposta data FizxMike 15.05.2016 - 02:05
-3

Hai provato a creare un altro script come questo, inserisci in kate:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

e salvalo come file jsin7 in / etc / network, e chiamalo network.d e potrebbe funzionare bene.

    
risposta data Michael 30.05.2014 - 11:45

Leggi altre domande sui tag