Come installare il pacchetto deb di Adobe Acrobat Reader scaricato dal sito Web di Adobe?

91

Sono nuovo di Ubuntu, ma credo di avere Ubuntu 11.10 installato correttamente. Sto cercando di installare Acroread utilizzando AdbeRdr9.4.6-1_i386linux_enu.deb scaricato dal sito Web di Adobe. Come faccio a fare questo?

    
posta ubuntu_rookie 20.12.2011 - 04:56

9 risposte

83

Tutte le versioni di Ubuntu precedenti alla 13.10

Per installare Adobe Acrobat è necessario abilitare il repository canonical partners nella scheda Sorgenti software di Update Manager

Usa Dash e cerca Sorgenti software o Software & amp; Aggiornamenti in 13.04 e successivi.

Se non vedi queste opzioni in Sorgenti software, puoi usare il seguente comando da un terminale:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Quindi in un terminale puoi aggiornare e installare acrobat reader:

sudo apt-get update
sudo apt-get install acroread

Si consiglia vivamente da un punto di vista della sicurezza di utilizzare la versione nei repository.

Se - per qualsiasi motivo - desideri scaricare direttamente da Adobe e installare, si applicano le seguenti istruzioni:

Usando firefox vai a:

Scegli le seguenti opzioni come mostrato nell'immagine: scarica il pacchetto .deb

Quando si fa clic sul pulsante Download:

Lascia il valore predefinito per aprirlo in Software Center dove puoi installarlo.

Se hai impostato i download per salvarli automaticamente nella cartella Download:

cd ~/Downloads
sudo dpkg -i AdbeRdr*.deb
    
risposta data fossfreedom 20.12.2011 - 10:59
79

REVISED: 2016-Nov ( solo parole minori )

Per Ubuntu 14.04 LTS, 16.04 LTS e 16.10, 32 o 64 bit

[adattato da: link ]

Adobe Reader 9 non è nel repository "Partner" per 13.10 (o successivo).

  1. Scarica Adobe Reader (32 bit), dal sito Adobe :

    Da qui: ftp. adobe.com .. reader .. 9.5.5

    Controlla MD5SUM dopo il download, inserisci

    md5sum AdbeRdr9.5.5-1_i386linux_enu.deb
    

    l'output dovrebbe essere

    88036c68998d565c4365e2ad89b04d51 AdbeRdr9.5.5-1_i386linux_enu.deb
    
  2. Apri una riga di comando, passa alla directory contenente il file .deb .

  3. Installa pacchetto, forzando ad accettare la versione a 32 bit e qualsiasi errore:

    sudo dpkg -i --force-architecture AdbeRdr9.5.5-1_i386linux_enu.deb
    sudo apt-get -f install
    
  4. Aggiungi le librerie a 32 bit mancanti: ( salta questo passaggio per 32-bit )

    sudo apt-get install libxml2:i386 lib32stdc++6
    
  5. (Opzionale) Esegui per la prima volta, per ottenere l'icona nella barra dei menu Unity.

    acroread <path>/<MyDocument>.pdf
    

Per Ubuntu 12.04 LTS

  1. Aggiungi repository "Canonical Partner"

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner"
    
  2. Aggiorna il tuo sistema

    sudo apt-get update
    
  3. Installa Adobe Reader e le estensioni dei caratteri

    sudo apt-get -y install acroread acroread-fonts
    
  4. (Opzionale) Esegui per la prima volta, per ottenere l'icona nella barra dei menu Unity.

    acroread <path>/<MyDocument>.pdf
    
risposta data david6 20.12.2011 - 05:05
9

Per saucy (13.10), è possibile includere il repository partner raro. Ecco come l'ho fatto:

sudo echo -e '# for acroread\ndeb http://archive.canonical.com/ubuntu/ raring partner' > /etc/apt/sources.list.d/raring-partner.list
sudo apt-get update
sudo apt-get install acroread

apt-cache show acroread
# Package: acroread
# Architecture: amd64
# Version: 9.5.5-1raring1
# Depends: debconf (>= 0.5) | debconf-2.0, acroread-bin, nspluginwrapper
# [...]

apt-cache policy acroread
# acroread:
#   Installiert:           9.5.5-1raring1
#   Installationskandidat: 9.5.5-1raring1
#   Versionstabelle:
#  *** 9.5.5-1raring1 0
#         500 http://archive.canonical.com/ubuntu/ raring/partner amd64 Packages
#         100 /var/lib/dpkg/status
    
risposta data MoreIT 22.01.2014 - 13:41
2

Sembra che Adobe non supporterà Linux nel prossimo futuro (vedi post qui ), a meno che non ci sia un aumento del numero di utenti Linux che richiedono supporto. Questo può essere fatto compilando il seguente modulo di richiesta delle funzioni di Adobe: Richiesta di funzionalità / Modulo di segnalazione bug .

In alternativa, potresti passare ai lettori Foxit o master pdf , che sono in realtà più veloci da aprire e offrono più funzioni gratuite del lettore Adobe.

    
risposta data Theodoros P. 02.03.2017 - 14:51
2

Ubuntu 16.10 su amd64 sembra richiedere

sudo apt-get -f install
sudo apt-get -y install adobereader-enu

Senza i386 in env acroread a 64 bit dà file not found e errori GTK, quindi esegui:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libncurses5:i386 libstdc++6:i386 libglib2.0-0:i386 libsoup2.4-1:i386 libgtk2.0-0:i386
sudo apt-get -y install libicu-dev:i386 gtk2-engines-murrine libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

Potrebbe essere ridondante poiché il cestino principale è i386

sudo apt-get -y install gtk2-engines gtk2-engines-* libgtkmm-2.4-1c2 libcanberra-gtk-module
    
risposta data jtm 14.04.2017 - 07:14
1

Acroread è ora disponibile nel repository partner di Quantal.

Vedi questo bug Launchpad:

Dice Precise nel titolo, ma si applica a preciso, quantico e raro.

    
risposta data Mark Russell 12.03.2013 - 21:26
0

Puoi fare:

# sudo dpkg -i AdbeRdr9.4.6-1_i386linux_enu.deb

Ma ti consiglio di provare come migliore lettore di pdf. È il valore predefinito in quant.

    
risposta data Óscar García Amor 06.11.2012 - 12:41
0

Ho combinato i metodi sopra e quindi posso installare Adobe Acrobat Reader su Ubuntu 16.04 LTS Xenial Xerus e Ubuntu 18.04 LTS Bionic Beaver :

cd ~/Downloads
wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get -y install libxml2:i386 libcanberra-gtk-module:i386 \
gtk2-engines-murrine:i386 libatk-adaptor:i386

sudo apt-get install ./AdbeRdr9.5.5-1_i386linux_enu.deb

Quindi puoi lanciarlo con acroread .

Nota: ciò che rende Adobe Reader quasi unico e utile: è la sua ricerca in file (accessibile premendo Ctrl + Shift + F ) .

    
risposta data N0rbert 05.05.2018 - 00:28
0

La risposta di NOrbert ha funzionato per me, ma solo quando ho aggiunto l'opzione --reinstall durante l'installazione del pacchetto acroread.

sudo apt-get install --reinstall ./AdbeRdr9.5.5-1_i386linux_enu.deb
    
risposta data Steve Newcomb 04.08.2018 - 21:24

Leggi altre domande sui tag