Avvio lento - "un processo di avvio è in esecuzione per dev-disk-by ..."

72

Non ricordo quando il problema ha avuto inizio ma è probabile che quando ho spostato la mia immagine VMWare Ubuntu su un SSD esterno in modo da poter utilizzare il sistema operativo su uno qualsiasi dei miei PC. Non ci sono molti link su Google riguardo al problema, ma quelli che appaiono parlano di fstab. Ad esempio ...

link

Le menzioni devono eliminare la partizione di swap e crearla nuovamente.

Posso provare a farlo con Gparted ma la mia preoccupazione principale è di perdere la configurazione attuale in Ubuntu perché non sono del tutto sicuro di cosa succederà se rovino lo swap come suggerito nel thread. Chiunque può aiutarti?

Screenshot

    
posta cpd1 18.12.2015 - 21:45

9 risposte

79

Se si ottiene "un processo di avvio avviato da dev-disk-by .." seguito da un ritardo di 90 secondi durante ciascun avvio, completare i seguenti passaggi:

  1. Installa gparted utilizzando il Centro software
  2. Apri gparted e guarda quali partizioni sta attualmente usando Ubuntu
  3. Modifica il file fstab utilizzando la riga sottostante.

    sudo -H gedit /etc/fstab
    
  4. Trova il dispositivo che non stai utilizzando attualmente

  5. Inserisci un # e uno spazio all'inizio di quella riga commentalo.

  6. Resetta, spero che funzioni per te!

risposta data William MacDonald 04.04.2016 - 07:06
27

Sembra che il problema sia dovuto al fatto che anche se fstab aveva una voce per uno scambio, in realtà non ce n'era uno. Ho usato GParted per ridimensionare la partizione e creato un nuovo Swap. Ho quindi copiato l'UUID nel file fstab ...

  1. Ora ho lo scambio
  2. E l'avvio è ridotto a pochi secondi rispetto a 90+ secondi
risposta data cpd1 31.12.2015 - 02:56
20

Ho lo stesso problema dopo aver ridimensionato la mia partizione primaria sulla mia VM dato che gparted live mi ha costretto a cancellare & amp; reinizializzare il mio scambio per farlo. Ciò ha causato l'impostazione di un nuovo UUID che non corrispondeva al file fstab.

Per evitare il problema, in /etc/fstab puoi

  • Sostituisci l'UUID di scambio con quello nuovo (esegui sudo blkid per trovarlo) dopo il ridimensionamento della partizione primaria.

  • Oppure commenta la partizione di swap prima (o dopo) il ridimensionamento della partizione primaria.

Consiglierei il primo poiché è il modo in cui il sistema operativo deve essere configurato.

    
risposta data Matthew Cordaro 09.08.2016 - 20:24
12

Nel mio caso, avevo precedentemente utilizzato lo swap crittografato e il lavoro di avvio menzionava /dev/mapper/cryptswap1 . Per risolvere il problema ho anche dovuto rimuovere il file /etc/crypttab , oltre ai passaggi descritti nella risposta di William MacDonald.

    
risposta data Kalle Elmér 28.09.2016 - 13:40
3

Quando ridimensiona o cancella le partizioni con gparted, devi spesso creare una nuova partizione di swap.

È quindi necessario attivare lo swap via gparted dopo la sua creazione (c'è il comando "Activate swap").

Inoltre devi copiare il nuovo UUID in / etc / fstab per montarlo altrimenti all'avvio il sistema operativo tenterà di trovarlo ma invano perché il file fstab contiene l'UUID che si riferisce al vecchio swap. Gparted fornisce le informazioni per l'UUID ma puoi facilmente eseguire il terminale:

sudo blkid

per trovarlo.

    
risposta data Alessandro D'lncal 01.09.2016 - 19:09
2

Ho avuto lo stesso problema all'avvio.

Nel mio file /etc/fstab , le mie partizioni sono state definite come /dev/sda1 , /dev/sda2 , ecc., ma all'avvio più volte è apparso il messaggio " Un processo di avvio è in esecuzione per dev-sdx "(" x "definisce quale unità o partizione è stata interessata).

Per risolverlo, ho cambiato il valore di /dev/sdx dall'UUID della partizione. Per vedere l'UUID, dall'esecuzione del terminale lsblk -f . Quindi, copia l'UUID della partizione interessata e scrivilo su /etc/fstab file, sostituendo /dev/sdax come segue: /dev/sda1 cambia in UUID=xxxxxxxxxxxxxxxxxx .

Ha funzionato per me, spero che questa informazione sia utile.

    
risposta data Lord Ferm 23.04.2017 - 11:30
1

Il mio avvio è stato rallentato perché ho sostituito la mia unità e l'UUID non corrispondeva. Ciò ha indotto Ubuntu a fare una scansione durante l'avvio.

Scambia spesso le unità in giro. Se i tuoi supporti sono sempre nello stesso posto (come il mio), puoi semplicemente rimuovere l'UUID e posizionare il percorso diretto per evitare che si verifichi l'errore di scansione ...

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/sda1 /               ext4    errors=remount-ro 0       1
/dev/sda2 none            swap    sw              0       0
    
risposta data Dan 25.01.2017 - 19:43
1

Puoi saltare l'attesa e andare direttamente alla schermata di accesso utilizzando ' Ctrl + c ' e quindi lavorare sulla soluzione. A volte questo andrà avanti per sempre se non.

    
risposta data Ramon Suarez 27.02.2017 - 12:55
0

Oltre a controllare /etc/fstab o /etc/crypttab come menzionato nelle altre risposte, controlla anche gli UUID provenienti dai parametri del kernel in /etc/default/grub . Per un po 'sono stato molto confuso da un sistema che aveva un /etc/fstab perfettamente cromatico solo per scoprire un parametro kernel resume=… nella configurazione di GRUB.

    
risposta data Random Poster 03.07.2018 - 16:03

Leggi altre domande sui tag