Come installo Adobe Acrobat in Ubuntu 16.04?

93

Conosco il thread Come installo il pacchetto deb di Adobe Acrobat Reader scaricato dal sito Web di Adobe? Tuttavia, non esiste Linux più nel sito di installazione qui . Tentativi non riusciti

  • Faccio la proposta di DriraWassim che non aggiunge nulla a apt-get e non mostra il pacchetto .deb installato nel percorso / ricerca

    sudo apt-get install libxml2:i386 
    sudo apt-get update
    sudo apt-get upgrade 
    apt-cache search adobereader-enu
    

    Ho scaricato il nuovo pacchetto .deb qui ed eseguilo Non riesco a trovare l'applicazione in qualsiasi parte del sistema. Non è nel percorso e non nella ricerca di Ubuntu. Come puoi avviarlo?

Sistema: Ubuntu 16.04, 64 bit
Hardware: Macbook Air 2013-mid
Kernel Linux: 4.6

    
posta Léo Léopold Hertz 준영 05.05.2016 - 12:50

7 risposte

109

Ho seguito i seguenti suggerimenti su Kubuntu 16.04 64 bit:

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt install adobereader-enu

Dopo aver installato Adobe Reader correttamente, non dimenticare di rimuovere il repository di Canonical Partners per Preciso:

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt update
    
risposta data A.Pereira 31.07.2016 - 22:17
36

Per Adobe Reader 9.5.5 (esecuzione nativamente senza Wine)

Non aggiungere il repository dei partner di Ubuntu 12.04, non devi in ​​realtà aggiungere repository dalle precedenti versioni di Ubuntu! Ottieni il Deb da qui ( fonte - è anche collegato alla domanda), no non verrà aggiornato automaticamente ma poiché non è più supportato (e Ubuntu non è in grado di applicare patch vulnerabilità di sicurezza per esso in Ubuntu 12.04 comunque perché è proprietario) non importa. C'è meno possibilità che rovini il tuo sistema se lo ottieni in questo modo.

Se non riesci a trovare / eseguire Adobe Reader, dovrai eseguire sudo apt -f install per risolvere le dipendenze. Se continua a non funzionare, prova sudo apt install libxml2:i386 .

Questa è, ovviamente, una versione obsoleta di Adobe Reader, ma questa non è colpa di Ubuntu, Adobe non ha aggiornato il client Linux di Adobe Reader. È possibile, tuttavia, ottenere una versione più recente utilizzando il processo seguente (installa una versione Windows di Adobe Reader su Ubuntu).

Per Adobe Reader DC 1501020056 (in esecuzione con Wine 1.9)

  1. Installa PlayOnLinux
  2. Carica PlayOnLinux
  3. Fai clic su "Installa" (nella barra degli strumenti)
  4. Digita "Adobe Acrobat Reader DC" nella barra di ricerca
  5. Fai clic su "Adobe Acrobat Reader DC"
  6. Fai clic su "Installa" (in basso a destra)
  7. Segui le schermate di installazione
  8. Una volta installato, fai clic su "Adobe Acrobat Reader DC"
  9. Fai clic su "Esegui" (nella barra degli strumenti)

Avrai bisogno di aprire PlayOnLinux per eseguire ogni volta Adobe Reader DC (nota che puoi averlo installato insieme ad Adobe Reader 9.5.5). Puoi trascinare il file desktop nel Launcher per ottenere un pulsante lì, puoi anche aggiungere un'icona per esso in Ubuntu Dash usando Alacarte ('Menu principale'). Potrei aggiungere delle istruzioni per dopo. Sfortunatamente nemmeno questa versione è completamente aggiornata (probabilmente ci sono anche vulnerabilità di sicurezza senza patch in quella versione e Wine è anche obsoleto qui, anche se non importa tanto). Per installare l'ultima versione di Reader, DC o non-DC, devi farlo manualmente usando PlayOnLinux. Potrei scrivere istruzioni per questo o scrivere uno script POL per farlo in un secondo momento.

    
risposta data Ads20000 20.11.2016 - 23:49
14

Sì, ma il supporto è stato eliminato. Controlla questo fuori e segui le istruzioni per l'installazione:

  
  1. Apri il terminale premendo Ctrl + Alt + T sulla tastiera. Quando si apre, incolla il comando qui sotto e premi invio per aggiungere il repository:

    sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
    
         

    Inserisci la tua password utente quando ti chiede. Nota che non c'è feed-back visivo quando si digita una password.

  2.   
  3. Dopo aver aggiunto il repository, aggiornare gli elenchi di pacchetti e installare il pacchetto acroread eseguendo i comandi sottostanti uno a uno:

    sudo apt-get update
    sudo apt-get install acroread
    
         

    Una volta installato, dovresti essere in grado di aprirlo dal dash Unity o dal menu Applicazioni.

  4.   
  5. Dopo aver installato Adobe Reader correttamente, non dimenticare di rimuovere il repository di Canonical Partners per Preciso:

    sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
    sudo apt-get update
    
  6.   
  7. Come impostare Adobe Reader come lettore PDF predefinito:

  8.   

Esegui il comando di seguito nel terminale per modificare il file di configurazione:

    sudo gedit /etc/gnome/defaults.list
     

Quando si apre il file, fai:

     

Scopri e cambia linea

application/pdf=evince.desktop
     

in:

application/pdf=acroread.desktop
     

Aggiungi sotto la riga alla fine:

application/fdf=acroread.desktop
application/xdp=acroread.desktop
application/xfdf=acroread.desktop
application/pdx=acroread.desktop
     

Infine salva il file e riavvia nautilus (esegui il comando nautilus -q nel terminale) per applicare le modifiche.

    
risposta data Mookey 05.05.2016 - 12:57
11

Dovresti essere in grado di scaricare il .deb da qui: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

e installarlo aprendo quel file. Prova ad installare attraverso il terminale per vedere eventuali errori se non funziona attraverso la GUI del gestore software: link

Solitamente apro i file con Acrobat usando il terminale e il comando acroread filename.pdf . Ci è voluto un po 'per aprire la prima volta che l'ho eseguito.

Quando l'ho installato di recente su Ubuntu 16.04, ho ricevuto alcuni errori:

libxml2.so.2: cannot open shared object file: No such file or directory

e

Gtk-Message: Failed to load module "canberra-gtk-module"

Li ho risolti con

sudo apt-get install libxml2:i386 libstdc++6:i386 (da qui )

e

sudo apt-get install libcanberra-gtk-module:i386 (da qui )

Apparentemente potrebbe esserci un altro errore relativo a adobereader-enu:i386 ; eseguire:

sudo apt-get install libgtk2.0-0
sudo apt-get -f install

Quindi installa nuovamente il file .deb e dovresti essere ordinato.

    
risposta data wordsforthewise 27.05.2017 - 06:04
8

Installazione di Dipendenze per Adobe Reader

sudo apt-get install gtk2-engines-murrine:i386 libcanberra-gtk-module:i386 libatk-adaptor:i386 libgail-common:i386

Installa Adobe Reader utilizzando i seguenti comandi

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update 
sudo apt-get install adobereader-enu

Dopo l'installazione, devi rimuovere il repository preciso usando i seguenti comandi

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update

Per la configurazione I Ho scritto un articolo breif Installazione di Adobe Reader su Ubuntu 16.04 / 16.06

    
risposta data MC Naveen 10.04.2017 - 18:50
2

L'ho trovato:

sudo apt install adoberead-enu

... genera un errore nell'impossibilità di trovare il pacchetto adoberead-enu. Tuttavia quando l'ho fatto:

sudo apt install adoberead-bin:i386

... ha funzionato, e il risultato sembra essere un Adobe Reader funzionante.

Sto usando Ubuntu 16.04.

    
risposta data Rolf Turner 27.09.2016 - 05:50
2

È ancora possibile utilizzare la sua ultima versione "Adobe Acrobat Reader DC" insieme al vino, sebbene Adobe abbia interrotto il proprio software di lettura PDF per Linux diversi anni fa. Funziona perfettamente per me.

Installa prima wine e winetricks

sudo apt install wine-stable winetricks

Prepara vino per ricevere l'installazione di Acrobat Reader DC:

winetricks mspatcha

Scarica l'ultima versione di Adobe Reader per Windows 10 dal sito ufficiale link

Verrà scaricato un file con estensione exe. (%codice%) Ora installa il file exe in wine:

wine AcroRdrDC1801120040_en_US.exe

(Usa lo stesso nome del file exe scaricato)

Fai clic sul pulsante AcroRdrDC1801120040_en_US.exe .

Attendi il completamento dell'impostazione e fai clic su Install .

Ora cerca Acrobat Reader nel menu delle applicazioni e aprilo.

Seleziona Finish . (Adobe Reader DC viene eseguito in modalità protetta per impostazione predefinita per fornire un ulteriore livello di sicurezza)

Accetta licenza.

Ora puoi aprire i tuoi file usando Acrobat Reader DC anche su Ubuntu.

    
risposta data Tejesh Raut 19.05.2018 - 09:42

Leggi altre domande sui tag