Come installo PostgreSQL 9.6 su qualsiasi versione di Ubuntu?

84

Come installo PostgreSQL 9.6 su qualsiasi versione di Ubuntu poiché non viene fornita di default con la versione più recente?

Ubuntu Xenial (16.04) viene fornito con PostgreSQL 9.5 dai repository predefiniti.

    
posta Victor 29.09.2016 - 19:38

3 risposte

181

Per le seguenti versioni di Ubuntu, puoi installare con i comandi dati, come per il Repository Apt di PostgreSQL .

Ubuntu 17.04 - 17.10

La versione 9.6 viene fornita con la distribuzione.

sudo apt-get install postgresql-9.6

Ubuntu 12.04, 14.04, 16.04

sudo add-apt-repository "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -sc)-pgdg main"
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install postgresql-9.6
    
risposta data Victor 29.09.2016 - 19:38
12

Segui i passaggi seguenti:

Riferimento è tratto da questo blog.

Devi aggiungere l'ultimo repository PostgreSQL per la versione più recente.

sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"

Aggiorna e installa PostgreSQL 9.6:

sudo apt-get update
sudo apt-get install postgresql-9.6

Viene creato il database predefinito postgres e postgres predefinito. Devi impostare una password per l'utente super postgres.

[email protected]:~$ sudo passwd postgres
Enter new UNIX password:****
Retype new UNIX password:****
passwd: password updated successfully

Se il servizio non è avviato, puoi avviare il servizio PostgreSQL.

sudo service postgresql start

Connetti il ​​server PostgreSQL usando l'utente postgres:

[email protected]:~$ su postgres
Password:****

Crea un database di esempio:

createdb database_name

Connetti a quel database:

psql -d database_name
    
risposta data Anvesh 18.01.2017 - 22:24
1

Ho seguito questo Github gist - Sto eseguendo Ubuntu xenial all'interno di vagabondo e volevo aggiornare la repository ufficiale postresql esistente dalla 9,5 alla 9,6 in modo da poter usare l'estensione PostGIS che è meglio servita da versione 9.6 (ufficialmente menzionata nel loro sito) Spero che questo aiuti qualcuno.

    
risposta data Sanchit 24.06.2017 - 16:09

Leggi altre domande sui tag