I blocchi della tastiera in IntelliJ IDEA su Ubuntu 14.04

165

Potresti aiutarmi con un problema strano? Uso Intellij IDEA 13 su Ubuntu 14.04 e di volta in volta la mia tastiera completamente (sì, completamente, non si tratta di scorciatoie) blocchi in IDEA. Posso ancora fare tutto ciò che voglio in IDEA con il mio mouse, inoltre posso usare la tastiera ovunque tranne IDEA. E può essere risolto solo riavviando IDEA finora.

Qualcuno può dare un suggerimento, per favore?

    
posta Treble Snake 24.07.2014 - 08:58

4 risposte

206

C'è un un problema aperto in jetbrains youtrack per l'idea intellij che consiglia due soluzioni:

  1. L'input della tastiera potrebbe essere sbloccato riavviando il demone IBus da una console:

    ibus-daemon -rd
    
  2. IBus può essere disabilitato per IDEA disabilitando env. XMODIFICATORI variabili, ma la capacità di inserire caratteri nazionali in IDEA andrà persa:

    XMODIFIERS="" idea.sh
    

Ho usato il secondo e ho risolto il mio problema.

    
risposta data Saeed Zarinfam 18.10.2014 - 18:50
14

Sono stato in grado di risolverlo con quello che ho trovato qui che fondamentalmente sta aggiungendo export XMODIFIERS="" a idea.sh

    
risposta data Alfergon 05.03.2015 - 17:45
5

Per una soluzione permanente , l' aggiornamento del 1 ° ottobre 2015 sul problema consiglia a:

Aggiornare IBus alla versione 1.5.11 o aggiungere export IBUS_ENABLE_SYNC_MODE=1 al ~/.profile , quindi riavviare una sessione.

In alternativa, puoi disattivare IBus a System Settings | Language Support | Keyboard input method .

IDEA 15 mostrerà un avviso se è in uso una versione incompatibile di IBus.

    
risposta data Alex 30.11.2015 - 12:53
1

Ho provato questo e il suo funzionamento finora, ma aggiornerò se si blocca di nuovo. Ho visto un suggerimento su youtrack che suggerisce di disattivare iBus che sembra interferire in particolare a causa dell'uso del collegamento ctrl + spazio per modificare le impostazioni della lingua. Puoi farlo andando a:

supporto per la lingua & gt; sistema di metodo di input da tastiera & gt; none

**** AGGIORNAMENTO *****

Dopo averlo eseguito per un po ', questa tecnica non funzionava ancora perché continuavo a congelare. Immagino per ora che seguirò la seguente soluzione alternativa per riavviare ibus, che è un po 'scomodo, ma cosa puoi fare.

entra nel terminale

Tipo:

ibus-daemon -rd
    
risposta data ThinkBonobo 05.04.2015 - 02:33

Leggi altre domande sui tag