Il desktop dimentica il tema?

78

Sto usando Ubuntu in VirtualBox (su un host Windows 7). Diverse volte, la barra dei menu di livello superiore, la barra delle applicazioni e, apparentemente, tutte le finestre di dialogo del sistema, hanno dimenticato il tema "Ambiance" immediatamente conforme alla prima installazione del sistema. Le didascalie delle finestre mantengono ancora il tema, ma praticamente nient'altro.

Ho cercato in alto e in basso su Google per assistenza con questo problema. Tutto quello che ho trovato suggerisce di eseguire alcuni reset di gconf o cancellare .gconf * .gnome * e altre directory simili. Ho seguito tutti questi consigli e niente funziona. Ho ancora un noioso aspetto 3D grigio stile Windows 95. In precedenti occasioni, dopo molti scherzi mi sono arreso e ho riavviato l'istanza VM, e sono stato piacevolmente sorpreso di vedere il tema "Ambiente" originale ripristinato nell'interfaccia utente, ma invariabilmente scompare di nuovo qualche tempo dopo, di solito dopo un riavvio, quindi non riesco mai a capire cosa ho fatto che lo ha rotto.

Ecco un esempio dal sito di Ubuntu su cosa voglio che assomigli.

Ed ecco uno screenshot del mio sistema come sembra attualmente.

Nota anche che i miei Terminali GNOME normalmente hanno un bel aspetto semitrasparente viola, e come si può vedere dallo screenshot, ora sono solo un solido bianco opaco.

Quest'ultima volta (solo ieri), provando numerose combinazioni, tutti i soliti trucchi e il riavvio più volte non l'ha risolto, quindi eccomi su SU chiedendomi:

Come faccio a recuperare il tema pronto all'uso per il mio desktop Gnome / Ubuntu, notando che spazzare via tutti i file di configurazione - come suggerito in molti posti online - non riesce a raggiungere questo obiettivo?

Potrebbe essere utile sapere che sembra fallire dopo aver ridimensionato l'istanza VM, forzando il ridimensionamento del desktop di Ubuntu o dopo aver giocato con le impostazioni di Compiz. Non sono stato in grado di capire quale di questi sia, e potrebbe non essere né l'uno né l'altro. Data la quantità di dolore che ho dovuto attraversare per riportare le cose alla normalità (e dato che sono in perdita su come farlo), è stato difficile isolare definitivamente la causa.

    
posta Marcelo Cantos 13.01.2011 - 03:09

15 risposte

45

la risposta di @ zpletan porta a un po 'di caccia intorno, che ha portato alla luce rapidamente quella che sembra essere la causa principale del mio problema. È dettagliato in Bug # 574296 di Ubuntu. In sintesi, il mio sistema Core i7 con un SSD avvia tutto con tempi sufficientemente diversi che gnome-settings-daemon viene eseguito troppo presto, bails e mi lascia principalmente con un tema GTK di riserva.

Un breve sonno in /etc/xdg/autostart/gnome-settings-daemon.desktop lo risolve:

Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"
    
risposta data Marcelo Cantos 17.01.2011 - 03:34
22

Non ho potuto risolvere questo problema con nessuna delle risposte suggerite (la risposta attualmente accettata funzionava sporadicamente, ma di solito non funzionava per me). Ho provato ad aumentare di molto il tempo di sonno e ancora non funzionava in modo coerente.

Tuttavia, una delle risposte ha indicato un bug che tiene traccia di questo problema, e ho trovato un commentare il bug che lo ha risolto per me.

Ecco i bit chiave:

Per prima cosa, crea uno script bash (l'ho chiamato /etc/xdg/autostart/gnomesettingsdaemonfix.sh )

#!/bin/bash

pid=$(pgrep gnome-settings-)

while [ -n "$pid" ];
do
  pid=$(pgrep gnome-settings-)
  sleep 0
done

exit 0

Assicurati che sia eseguibile (esegui chmod +x ).

Quindi modifica /etc/xdg/autostart/gnome-settings-daemon.desktop

Cambia la riga Exec in:

Exec=bash -c '/etc/xdg/autostart/gnomesettingsdaemonfix.sh;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Questo sembra averlo risolto finora per me.

    
risposta data TM. 15.05.2011 - 23:49
16

Premere Alt + F2 (Esegui applicazione) ed eseguire quanto segue:

gksudo gnome-settings-daemon
    
risposta data zpletan 14.01.2011 - 13:13
7

10.10 ha questo problema, ma normalmente accade quando installi il driver nvidia proprietario. Tuttavia, la soluzione probabilmente funzionerà anche su una macchina virtuale.

Crea un file di testo. Scrivici

include "/usr/share/themes/Ambiance/gtk-2.0/gtkrc"
gtk-icon-theme-name = "ubuntu-mono-dark"

e salvarlo nella cartella home con il nome .gtkrc-2.0. Ricomincia.

Se ci sono ancora elementi sbagliati (per me era il font), devi aggiungere questa modifica al file, google per un tutorial gtk per le possibili regolazioni fini.

    
risposta data rumtscho 13.01.2011 - 08:55
4

Ho cercato una soluzione per questo problema per mesi. Apparentemente nessuno sa cosa lo causa. Questo bug esiste da anni e nessuno lo ha risolto.

A volte capita durante l'avvio con una condizione di competizione tra la prima e la seconda istanza di gnome-settings-daemon, ea volte capita nel mezzo di una sessione desktop di lavoro quando gnome-settings-daemon smette di funzionare o si blocca.

L'unica soluzione che ho trovato sembra risolvere il problema digitando

killall gnome-settings-daemon
gnome-settings-daemon &

in un terminale in esecuzione che lascio aperto.

Chiudendo il terminale si uccide l'istanza di base di gnome-settings-daemon e il desktop torna al tema predefinito (non predefinito di Ubuntu ma predefinito di gnome). Perciò eseguo il daemon in background e lascia il terminale in esecuzione anche perché il processo ha bisogno del suo genitore.

    
risposta data Cheryl 23.01.2012 - 14:10
4

Ho avuto lo stesso problema e ho riscontrato un errore nell'accattonaggio: Could not apply the stored configuration for monitors.

Rimosso il file: ~/.config/monitors.xml registrato nuovamente e funzionava come un guanto.

    
risposta data topless 12.10.2011 - 21:08
2

Ho lo stesso problema, sudo killall nautilus lo risolve. (Temporaneamente)

    
risposta data Pit 14.01.2011 - 09:12
1

Scusa ma il mio precedente suggerimento di usare '--sync' non è una soluzione. Si scopre che dopo alcuni riavvii il problema è lo stesso.

Ma spero di essere riuscito a catturare il seguente output dal crash del processo 'gnome-settings-daemon' durante l'avvio quando il tema non si applica:

** (gnome-settings-daemon:1679): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1679): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

Quando il tema viene applicato correttamente, non viene visualizzato alcun output.

Da questo, sembra che gnome-settings-daemon possa essere eseguito due volte in qualche modo. Apparentemente, se la prima istanza si completa prima che venga eseguita la seconda istanza, il tema verrà applicato altrimenti fallirà.

NOTA: L'acquisizione dell'output è stata eseguita modificando /etc/xdg/autostart/gnome-settings-daemon.desktop's 'Exec =' voce in "bash -c" / usr / lib / gnome-settings-daemon / gnome- settings-daemon --debug --sync & amp; & gt; /home/sanjeev/Desktop/test.txt '"(l'opzione --sync è stata utilizzata come consigliato da alcuni siti Web)

PS: ulteriori test, mostra che esistono effettivamente due istanze in esecuzione che dovrebbero essere eseguite una dopo l'altra.

Sebbene il metodo "sleep" possa fare, ecco una soluzione più "tecnicamente corretta", se posso, soluzione al problema. Ho provato con 6 riavvii e il seguente sembra funzionare:

Passaggio 1: Crea uno script (l'ho chiamato gnome-settings-daemon-fix.sh) in / etc / xdg / autostart con il seguente:

#!/bin/bash
# gnome-settings-daemon-fix.sh

pid='pgrep gnome-settings-'
wait pid

exit 0

Passaggio 2: modifica "gnome-settings-daemon.desktop" sotto "Exec=" e sostituiscilo con:

Exec=bash -c 'bash /etc/xdg/autostart/gnome-settings-daemon-fix.sh ;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Ogni cosa è fatta. Fondamentalmente, quello che stiamo facendo è aspettare che la prima istanza esca prima che venga lanciato il secondo. Qualcuno potrebbe avvisare se questo ha risolto il problema?

    
risposta data Sanjeev 28.03.2011 - 01:33
1

Ho avuto anche il problema molto simile. Questo è stato dopo un aggiornamento (IIRC parziale) del mio Natty Narwhal come lo era alfa 3. Nel mio caso, il file ~ / michael / .nautilus / browser.xml sembrava essere corrotto. Dopo aver provato alcuni dei suggerimenti di questo sito parziale ho semplicemente cancellato questo file, riavviato il mio pc e tutti i miei temi sono tornati e sono rimasti stabili. Penso che tu possa provare a risolvere il tuo problema come me.

    
risposta data Michael Staengl 08.05.2011 - 10:23
1

Questo mi capita occasionalmente con 11.04 Unity 3D e ogni volta che l'ho cancellato aprendo il pulsante Aspetto, Personalizza, scheda Icona e facendo clic sul mio set di icone scelto anche se era indicato come in uso. Nel mio caso sarebbe Faenza-Dark. Succede così raramente che devo ancora identificare una sequenza di eventi che causi questo.

    
risposta data fragos 28.08.2011 - 22:58
1

Questo ha funzionato per me in una finestra di terminale:

echo "PATH=\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games\"" | tee -a ~/.profile
    
risposta data user10655 08.07.2011 - 05:43
1

Ecco una soluzione rapida, vai alla tua console virtuale, ferma gdm, avvia X server

  1. premi "Ctrl destro + F1" (Ctrl + Alt + F1 è una combinazione per installazioni non virtualizzate)
  2. accedi
  3. tipo: sudo /etc/init.d/gdm stop
  4. tipo: startx

dato che questo è il mio primo post, ho dovuto inserire immagini come questa:

link

    
risposta data nidla 09.11.2011 - 10:18
1

Questo è successo anche a me e nel mio caso, ho dovuto nuotare la mia intera home directory e poi ripristinare pezzi e pezzi, per la risposta qui . Se si stanno eseguendo gli script di temporizzazione per gnome-settings-daemon, vedere se è possibile farlo funzionare correttamente creando un altro account ed eseguendo l'accesso come tale account. Nel mio caso, il secondo account non ha avuto il problema di non inizio e, quindi, ho applicato la correzione nel link.

    
risposta data mfisch 12.12.2011 - 07:41
0

Per favore, prova questo e riavvia! :)

gconftool-2 --shutdown        
rm -rf ~/.gconf/apps/panel       
pkill gnome-panel        
    
risposta data Iván Stojanovic 13.01.2011 - 03:20
0

Penso che ci siano molte persone con l'idea giusta.

La mia ipotesi è che dopo determinati aggiornamenti (nuovi kernel, ecc.) che ureadahead venga riprogrammato. Questo è dove penso che il problema si verifichi. gnome-settings-daemon viene chiamato troppo presto.

Ho cancellato tutti i file con 'pack' (pack, home.pack, boot.pack, run.pack) nel nome in / var / lib / ureadahead / folder per forzare un reprofile. Tutto è andato benissimo dopo.

Durante la riprofilatura, cancella i file sopra, riavvia e accedi rapidamente non appena vedi la schermata di accesso. Attendere circa 30 secondi o quando l'unità smette di ruotare prima di eseguire qualsiasi operazione. Lascia che finisca la sua attività. La tua finestra nautilus dovrebbe apparire a posto ora.

Forse un errore dovrebbe essere archiviato con ureadahead per mettere fuori servizio gnome-settings-daemon.

    
risposta data user32089 10.04.2012 - 09:50

Leggi altre domande sui tag