google-chrome-stable continua a chiedere se dovrebbe essere impostato su default

77

Dall'aggiornamento di Ubuntu 15.10, google-chrome-stable continua a chiedere se dovrebbe essere impostato come browser predefinito, anche se lo è già. Ho provato a reinstallarlo, ma quello non ha aiutato. Qualche idea?

    
posta Yanick Nedderhoff 23.10.2015 - 10:07

3 risposte

54

Per la correzione di lavoro, vedi la fine di questa risposta.

RISPOSTA INIZIALE 28 ottobre 2015 (correzione non aggiornata)

Per evitare di essere chiesto se si desidera utilizzare Chrome come browser predefinito, utilizzare la seguente soluzione alternativa (proposta qui e suggerito nella sezione commenti di questa domanda da Yurii Kolesnykov ):

Apri il file ~/.config/google-chrome/Default/Preferences con un editor di testo.

Trova la linea

"check_default_browser": true,

e sostituirlo con

"check_default_browser": false,

Nel mio caso, il file era & gt; 200k caratteri, per cui motivo gedit si è bloccato alcune volte. Se è lo stesso nel tuo caso, probabilmente vorresti usare un editor basato sul terminale come vi.

Tieni presente che questa è una soluzione alternativa, il problema deve essere risolto dagli sviluppatori di Chrome.

UPDATE 24 novembre 2015

Come menzionato Danilo Piazzalunga , il bug è confermato . Come suggerito NicDumZ , vota questo errore facendo clic su

per attirare l'attenzione. Grazie!

AGGIORNAMENTO, 20 febbraio 2016

Come riportato prima da Ron Thompson e 3vi1 nella sezione dei commenti; e infine confermato da me stesso (usando Ubuntu 15.10), questa soluzione non sembra funzionare più, almeno non per tutti, dopo aver reinstallato google-chrome. Chiunque abbia utilizzato questa soluzione alternativa dovrebbe cercare di evitare la reinstallazione di chrome.

Ti incoraggio nuovamente a dire che sei affetto dal bug su launchpad (attualmente 302 persone).

AGGIORNAMENTO 5 aprile 2016 (Correzione di lavoro!)

Una correzione è stata proposta su launchpad che a quanto pare ha fatto il lavoro per un paio di persone:

Per applicare la correzione, modifica la riga # 198 nel file /usr/bin/xdg-settings da

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//''"

a

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//' | head -n 1'"

AGGIORNAMENTO 25 luglio 2016 (Correzione di lavoro!)

Aggiornamento alla correzione proposta per (K) Ubuntu 16.04:

Per applicare la correzione, modifica le linee # 177 e # 202 nel file /usr/bin/xdg-settings da

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word"

a

command="'grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word | head -n 1'"

Quindi vai alle impostazioni di Google Chrome e imposta Chrome come browser predefinito.

UPDATE 1 giugno 2017

Il Bug è stato chiuso e contrassegnato come "Risolto il rilascio" a partire da oggi. Citando l'utente Olivier Tilloy (osomon) :

  

Se ho letto correttamente il rapporto, il problema è stato risolto in xdg-utils in xenial. Wily è stato EOL per quasi un anno, quindi sto chiudendo il bug.

     

no longer affects: chromium-browser no longer affects: google-chrome-beta (Ubuntu) no longer affects: google-chrome (Ubuntu) Changed in chromium-browser (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: In Progress → Invalid Changed in xdg-utils (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: Confirmed → Fix Released

    
risposta data Yanick Nedderhoff 28.10.2015 - 12:48
3

Questo è stato rintracciato come bug nelle utility XDG e ha effetto anche su Chromium Browser.

Vedi LP Bug # 1509139 .

    
risposta data Danilo Piazzalunga 11.11.2015 - 23:01
-1

Stavo avendo lo stesso problema con 15.10. Ogni volta che ho riavviato e avviato Chrome, si lamentava che non era il browser predefinito anche se le impostazioni dettagli Applicazioni predefinite lo mostra come predefinito per il web. Ho notato che Firefox era predefinito per le foto, quindi impostalo sul visualizzatore di immagini. Dopo un totale di un riavvio, Chrome non si lamenta più. Dovrei provare ancora un paio di volte prima di affermare che questo ha risolto il mio problema, ma ho voluto condividere il risultato iniziale se qualcuno si trova nella modalità di provare le cose da sé.

    
risposta data mrh53 31.12.2015 - 18:22

Leggi altre domande sui tag