Come faccio a far funzionare il plugin Java su Google Chrome?

62

Google ha aggiornato il suo browser Chrome alla versione 35. Questa nuova versione utilizza Aura al posto di GTK2 e non supporta più i plugin NPAPI come Java (sia OpenJDK che Oracle) . I plugin PPAPI come PepperFlash funzionano ancora.

La mia scuola utilizza Google Chrome e le app di Google ogni giorno e questo sembra potenzialmente un grosso problema per alcuni dei siti web educativi che utilizziamo. Qualcuno si imbatte in una soluzione o soluzione alternativa per far funzionare Java?

Questo articolo WEB UPD8 conferma che Java non funziona .

    
posta HarlemSquirrel 22.05.2014 - 14:02

2 risposte

56

Non puoi far funzionare Java su Chrome 35. È a causa della rimozione del vecchio plug-in NPAPI. Ho sollevato un bug report. In attesa di una risposta adeguata da parte degli sviluppatori. Il bug report è qui: link . Puoi provare e seguire la discussione per questa discussione qui: link

Aggiorna Sembra che resteremo bloccati qui per un bel po '. Il mio bug report è stato unito al bug parent ed è stato impostato come non verrà risolto. Eccolo: link

UPDATE2 Una domanda pertinente è stata inviata a Oracle. Non molta trazione. Ragazzi, potete iniziare una discussione su quel thread. Vai qui: link

A tutti voi: per mantenere il funzionamento di Chrome, esegui il downgrade di Google Chrome a 34. Puoi scaricare il deb qui: link . Quindi utilizzare il gestore di pacchetti synaptic o utilizzare la riga di comando per bloccare gli aggiornamenti per il pacchetto google-chrome-stable. Chrome 34 non ha bug abbaglianti, quindi puoi utilizzarlo in sicurezza per i prossimi 3 mesi. Spero che a quel punto verrà aggiunta una patch.

    
risposta data Ubuntuser 22.05.2014 - 20:38
2

Tu CAN fai in modo che Java funzioni su Chrome, o almeno abiliti il ​​plug-in NPAPI per questo ... temporaneamente. L'opzione viene rimossa completamente in Chrome 45. (Attualmente siamo a 43, stima è settembre 2015.)

Si noti che l'abilitazione di NPAPI non significa necessariamente che l'applet Java funzionerà ... L'ho provato con uno e non l'ha fatto. Questo probabilmente è dovuto all'installazione dell'ultima versione di Java, che blocca praticamente qualsiasi accesso al web. Il che è un peccato, dal momento che sono stati creati tanti servizi Web con funzionalità Java avanzate (come link .)

In ogni caso, l'opzione per abilitare NPAPI si trova sfogliando a:

chrome://flags/#enable-npapi

Anche in questo caso, il tuo chilometraggio può variare (YMMV.)

    
risposta data rdtsc 15.06.2015 - 17:46

Leggi altre domande sui tag