Domande con tag 'dpkg'

7
risposte

Come posso ottenere un elenco di file installati da un pacchetto?

Voglio sapere dove posso trovare la mia applicazione installata quando l'ho installata su Ubuntu usando il gestore dei pacchetti. Ho installato RabbitMQ e ho eseguito locate rabbitmq che mi ha dato il seguente risultato: /home/anupamg/.m...
posta 29.03.2011 - 11:57
3
risposte

Qual è la differenza tra dpkg e aptitude / apt-get?

Quando si installa un software tramite dpkg -i packageA.deb , le dipendenze richieste da packageA verranno scaricate e installate automaticamente? In che modo è diverso dall'utilizzare apt-get o aptitude ?     
posta 17.06.2013 - 09:08
7
risposte

Come recuperare automaticamente le dipendenze mancanti durante l'installazione del software da .deb? [duplicare]

     Questa domanda ha già una risposta qui:                   Come consentire a 'dpkg -i' di installare le dipendenze per me?                                      10 risposte                                Sto cercando di installa...
posta 22.08.2011 - 13:34
10
risposte

Come consentire a 'dpkg -i' di installare le dipendenze per me?

Dire, ho foo-1.2.3.deb che dipende da perl e python , tuttavia, comando di esecuzione: dpkg -i ./foo-1.2.3.deb non installerà queste dipendenze. Quindi devo apt-get install perl python a mano. Come rendere dpkg -i installar...
posta 04.05.2011 - 15:11
4
risposte

Che cosa significano i vari flag di dpkg come "ii" "rc"?

Ho spesso bisogno di controllare quali pacchetti sono installati, e io uso il seguente comando: dpkg -l | grep foo che fornisce il seguente output Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Cfg-files/Unpacked/Failed-c...
posta 25.12.2010 - 10:02
5
risposte

Come posso trovare il numero di versione di un pacchetto installato tramite dpkg?

Uso il comando dpkg -l per scoprire quale versione di un pacchetto ho installato. Ad esempio: dpkg -l network-manager restituisce le informazioni sul pacchetto: Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unp...
posta 30.11.2010 - 07:20
4
risposte

errore dpkg: "prova a sovrascrivere il file, che è anche in ..."

Ad esempio: $ sudo apt-get install curl Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: bsh :...
posta 15.08.2012 - 14:31
4
risposte

Installato Teamviewer che utilizza un sistema a 64 bit, ma ottengo un errore di dipendenza

Stavo cercando di installare Teamviewer, ma stavo ottenendo un errore di dipendenza. Ho provato ad installare i pacchetti richiesti, ma senza fortuna. Ho ricevuto questo errore: Unpacking teamviewer (from teamviewer_linux_x64.deb) ... dpkg:...
posta 21.10.2013 - 11:13
10
risposte

È possibile installare un .deb da un URL?

C'è un modo per installare un pacchetto deb direttamente da un URL, usando una shell ? Qualcosa come dpkg -i http://domain.com/path/to/package.deb (So che potrei usare wget e poi dpkg, mi stavo chiedendo se c'è qualcosa che lo fa già)  ...
posta 05.07.2011 - 12:28
2
risposte

Impossibile installare 'openjdk-9-jdk' perché prova a sovrascrivere i file già inclusi in 'openjdk-9-jdk-headless' [duplicato]

Utilizzo il desktop Xenial di Ubuntu 16.04, 64 bit, e ho voluto installare openjdk-9-jdk (kit di sviluppo Java 9). La versione disponibile dal repository universe è 9~b114-0ubuntu1 . L'esecuzione del comando di installazione install...
posta 08.05.2016 - 21:34