Domande con tag 'package-management'

10
risposte

È possibile installare un .deb da un URL?

C'è un modo per installare un pacchetto deb direttamente da un URL, usando una shell ? Qualcosa come dpkg -i http://domain.com/path/to/package.deb (So che potrei usare wget e poi dpkg, mi stavo chiedendo se c'è qualcosa che lo fa già)  ...
posta 05.07.2011 - 12:28
5
risposte

Come faccio a rilevare e rimuovere i pacchetti Python installati tramite pip?

Ho accidentalmente installato pacchetti Python sul mio sistema usando pip invece di apt-get . L'ho fatto in due modi: utilizzando una versione precedente di virtualenv, ho dimenticato di aggiungere --no-site-packages durante la creaz...
posta 08.08.2012 - 10:48
2
risposte

Impossibile installare 'openjdk-9-jdk' perché prova a sovrascrivere i file già inclusi in 'openjdk-9-jdk-headless' [duplicato]

Utilizzo il desktop Xenial di Ubuntu 16.04, 64 bit, e ho voluto installare openjdk-9-jdk (kit di sviluppo Java 9). La versione disponibile dal repository universe è 9~b114-0ubuntu1 . L'esecuzione del comando di installazione install...
posta 08.05.2016 - 21:34
1
risposta

Qual è la differenza tra upstream e downstream quando ci si riferisce a chi andare come sviluppatore?

Qual è la differenza tra upstream e downstream quando ci si riferisce a chi (o dove) andare come sviluppatore o packager?     
posta 28.09.2010 - 22:02
7
risposte

Perché i repository di Ubuntu non hanno le ultime versioni del software?

Perché i pacchetti nei repository ufficiali di Ubuntu sono più vecchi delle versioni più recenti (upstream) di Debian Sid, PPA, gli autori, ecc.?     
posta 15.06.2012 - 16:20
7
risposte

Come risolvere il problema "Il pacchetto è in uno stato di incoerenza molto cattivo"?

Non riesco ad aggiornare il mio sistema perché si blocca durante l'installazione di un aggiornamento di terze parti (zramswap-enabler)! A volte ricevo il seguente messaggio in Gestione aggiornamenti:    Impossibile inizializzare le informa...
posta 09.06.2012 - 21:51
4
risposte

Qual è il pacchetto di sviluppo per Qt5 in 14.04

Voglio creare un esempio Qt5 sulla mia macchina desktop. Ho installato qt5-default e qtdeclarative5-dev , ma sto ancora ricevendo questo errore: Project ERROR: Unknown module(s) in QT: quick qml Quale pacchetto dovrebbe essere installa...
posta 08.08.2014 - 10:06
3
risposte

Cosa significa che un pacchetto è "impostato per l'installazione manuale?"

Quando i pacchetti sono già installati e eseguo un apt-get install <package-name> , a volte stamperà una riga <package-name> is set to manually installed . Che cosa significa?     
posta 04.08.2010 - 22:29
6
risposte

Come posso verificare se un pacchetto è installato (nessun privilegio di superutente)?

Nella nostra università possiamo installare quasi tutti i pacchetti ubuntu che vogliamo, ma non siamo superutenti (dobbiamo richiedere l'installazione dei pacchetti). Con alcune librerie non è sempre facile sapere se il pacchetto è già instal...
posta 23.08.2010 - 15:33
10
risposte

Come posso spogliare Ubuntu?

Sto provando a sistemare quella che considero un'installazione gonfia di Ubuntu. Quando installo Ubuntu su una macchina, ottengo cose che non voglio: browser Web, applicazioni per ufficio, lettori multimediali, utilità di accessibilità, Ubuntu O...
posta 10.08.2010 - 00:55